Bug 1031769 - Invalid permissions on pom.properties for zip artifact types
Invalid permissions on pom.properties for zip artifact types
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
20
All Linux
high Severity high
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 12:50 EST by Roland Grunberg
Modified: 2014-02-03 09:34 EST (History)
7 users (show)

See Also:
Fixed In Version: 3.4.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 09:34:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Grunberg 2013-11-18 12:50:34 EST
After trying a rebuild of Tycho on f20 with xmvn-1.3.0-2.fc20.noarch I'm still noticing invalid permissions on pom.properties and all along the directory path META-INF/maven/$gid/$aid/ 

$ zipinfo -l usr/share/java/tycho/tycho-standalone-p2-director.zip

?rw-------  2.0 unx        0 b-        0 stor 13-Nov-18 17:38 META-INF/maven/org.eclipse.tycho/tycho-standalone-p2-director/
?rw-------  2.0 unx        0 b-        0 stor 13-Nov-18 17:38 META-INF/maven/org.eclipse.tycho/
?rw-------  2.0 unx        0 b-        0 stor 13-Nov-18 17:38 META-INF/maven/
?rw-------  2.0 unx        0 b-        0 stor 13-Nov-18 17:38 META-INF/
?rw-------  2.0 unx      154 b-      154 stor 13-Nov-18 17:38 META-INF/maven/org.eclipse.tycho/tycho-standalone-p2-director/pom.properties

I remember hearing that this file (pom.properties) would eventually disappear. Is this still planned for f20 ?
Comment 1 Alexander Kurtakov 2013-11-18 12:55:26 EST
Stano, can we get this fixed or workarounded somehow as it's a PITA to keep root console so you can clean the buildroot?
Comment 2 Stanislav Ochotnicky 2013-11-20 09:20:02 EST
Does javapackages-tools-3.4.1-2.fc21 fix your issues? If you can verify rawhide I'll backport/update F20.
Comment 3 Roland Grunberg 2013-11-20 09:44:50 EST
This works for me (folders are given the proper permissions). Tested by rebuilding affected package (Tycho).
Comment 4 Mikolaj Izdebski 2013-12-09 09:13:25 EST
Wrong component. Reassigning to javapackages-tools.
Comment 5 Mikolaj Izdebski 2014-02-03 09:34:22 EST
Fixed in F21 in 3.4.2-1.
For now there are no plans to backport this.
Reopen if you need a backport.

Build: http://koji.fedoraproject.org/koji/buildinfo?buildID=482927

Note You need to log in before you can comment on or make changes to this bug.