Bug 1031784 - Need ability to select sub-group members
Need ability to select sub-group members
Status: CLOSED DUPLICATE of bug 832398
Product: JBoss Operations Network
Classification: JBoss
Component: Inventory (Show other bugs)
JON 3.1.2
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 13:30 EST by Peter Larsen
Modified: 2014-02-24 10:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-24 09:50:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Larsen 2013-11-18 13:30:00 EST
Description of problem:

When creating groups - organizing very large inventories of hundreds of nodes, as an admin user you're often faced with grouping of servers into "management group", like Development, QA, Staging, Prod and even within Prod there may be parallel environments with hundreds of hosts each. 

When creating groups to reflect this, you're faced with creating groups of sub-services, such as SOA services, web services etc. for each of the super-seeding groups. To do this, using the UI you have no help. Out of 1000 platforms, you again and again have to remember the hosts that are part of the over-arching group you're working with Even worse, if more systems are added to that over-arching group you have a lot of editing to do. In many cases, the service/item name does not even reflect the hostname making it very hard to differentiate between them for selection.

WHAT IS NEEDED

Creating dynamic groups where group membership of the parent can be specified as a condition. 

When creating compatible groups, be able to restrict the number of items listed as items from another existing group. So if creating a group of SOA ESB services, it would only show the ESB services that can be found in a specific parent group.
Comment 5 Larry O'Leary 2014-02-24 09:50:26 EST
The capability to create a group based on members of another group was introduced in JBoss ON 3.2 as indicated in comment 2. This was done in the work for BZ832398.

*** This bug has been marked as a duplicate of bug 832398 ***

Note You need to log in before you can comment on or make changes to this bug.