Bug 103179 - NFS client has empty dirs
NFS client has empty dirs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 08:37 EDT by Elliot Lee
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 05:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliot Lee 2003-08-27 08:37:38 EDT
On ppc64 (411) and ia64 (382) directories sometimes appear to be empty even when
they are not. Touching a file inside the 'empty' directory makes the full
contents appear.
Comment 1 Steve Dickson 2003-08-27 08:42:16 EDT
What are the steps to reproduce this problem....
Comment 2 Elliot Lee 2003-08-27 08:50:38 EDT
Run a complete beehive installation?

I haven't the foggiest.

The basic set of operations that causes the path to come into existence are:

1. Populate directory while it is at a different path
2. Move parent directory to a new location.

e.g.


mkdir -p /tmp/foo/ppc64 # On the NFS server box
# On an NFS client box, not necessarily the one where the problem shows up
echo blah > /tmp/foo/ppc64/dummy.txt
mv /tmp/foo /tmp/blah # On the NFS server box

ls /tmp/blah/ppc64 # On the NFS client box in question, should show files but doesn't
Comment 3 Steve Dickson 2003-08-27 16:07:52 EDT
There is nfs.o on cur81 in /tmp that I would you to try....
Comment 8 Steve Dickson 2004-08-03 05:47:16 EDT
Since I not heard about this happen in later releases,
I'm going to assume its fixed. Please reopen if this
is not the case....

Note You need to log in before you can comment on or make changes to this bug.