Bug 1031807 - sssd_be segfaults when using the AD group matching ldap option.
Summary: sssd_be segfaults when using the AD group matching ldap option.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.4
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
: 1079585 (view as bug list)
Depends On:
Blocks: 1061410
TreeView+ depends on / blocked
 
Reported: 2013-11-18 20:06 UTC by hgraham
Modified: 2018-12-09 17:18 UTC (History)
11 users (show)

Fixed In Version: sssd-1.11.5.1-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: User configures SSSD to use ad_matching_rule and there are no group members. Consequence: SSSD accesses random data and crashes. Fix: Prevent SSSD from accessing random data. Result: SSSD does not crash when using the AD group matching ldap option.
Clone Of:
Environment:
Last Closed: 2014-10-14 04:47:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1375 normal SHIPPED_LIVE sssd bug fix and enhancement update 2014-10-14 01:06:25 UTC

Description hgraham 2013-11-18 20:06:17 UTC
Description of problem:
If the user configures sssd to use ad_matching_rule and there are no group members, the SSSD accesses random data and crashes. 

Version-Release number of selected component (if applicable):
sssd-1.9.2-82.10.el6_4.x86_64

How reproducible:
easy to reproduce

Steps to Reproduce:
1. Configure sssd to use ad_matching_rule and there are no group members,

Actual results:
sssd_be segfaults:
kernel: sssd_be[16228]: segfault at 0 ip 00007f8f43f4b68e sp 00007fffc48d6850 error 4 in libsss_ldap.so[7f8f43e81000+150000]

Expected results:
sssd doesn't crash

Additional info:
Upstream bug
https://fedorahosted.org/sssd/ticket/2157

Comment 1 Jakub Hrozek 2013-11-18 20:30:00 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2157

Comment 4 Jakub Hrozek 2013-11-28 09:51:18 UTC
Fixed upstream:
    master: 7a8f19affd2a050fd2e9631a54c0e67048d3920c
    sssd-1-11: c55ba1127071f7e6a622d8655d89726128d73981
    sssd-1-9: 9fcfa6c6e0469b955459f5df7309df28e0f07cf7

Comment 6 Jakub Hrozek 2014-04-23 07:24:46 UTC
*** Bug 1079585 has been marked as a duplicate of this bug. ***

Comment 12 Kaushik Banerjee 2014-07-09 04:35:30 UTC
Verified with sssd-1.11.6-1.el6

Output from beaker automation run:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: bug_automation_002: bz 1033084 empty group cannot be resolved using ad_matching_rule
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

empty_group:*:781293067:
:: [   PASS   ] :: Running 'getent group empty_group' (Expected 0, got 0)
bug-automation-002 result: PASS

Comment 13 errata-xmlrpc 2014-10-14 04:47:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1375.html


Note You need to log in before you can comment on or make changes to this bug.