Bug 1031819 - [rhq plugin] Manual discovery triggers ClassCastException
[rhq plugin] Manual discovery triggers ClassCastException
Status: CLOSED DUPLICATE of bug 1018270
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: JON (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Julian Coleman
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 16:01 EST by Viet Nguyen
Modified: 2015-08-02 19:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 16:14:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viet Nguyen 2013-11-18 16:01:10 EST
Description of problem:

Manual discovery scan triggers a ClassCastException.  Does not seem to affect discovery and import of SOA instance.


---
Exception in agent.log

2013-11-18 15:31:14,201 INFO  [InventoryManager.discovery-1] (rhq.core.pc.inventory.InventoryManager)- Syncing local inventory with Server inventory...
2013-11-18 15:31:14,203 INFO  [InventoryManager.discovery-1] (rhq.core.pc.inventory.RuntimeDiscoveryExecutor)- Executing runtime discovery scan rooted at [platform]...
2013-11-18 15:31:14,841 INFO  [InventoryManager.availability-1] (rhq.core.pc.inventory.AvailabilityExecutor)- Scan Ended   : Mon Nov 18 15:31:14 EST 2013 : Scan [startTime=138480667
3719, endTime=1384806674841, runtime=1122, isFull=true, isForced=false, numResources=638, numGetAvailabilityCalls=27, numScheduledRandomly=0, numPushedByInterval=26, numAvailability
Changes=0, numDeferToParent=0]
2013-11-18 15:31:22,825 WARN  [InventoryManager.discovery-1] (rhq.core.pc.inventory.InventoryManager)- Failure during discovery for [Deployments] Resources - failed after 1 ms.
java.lang.Exception: Discovery component invocation failed.
        at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:309)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)
Caused by: java.lang.ClassCastException: org.rhq.modules.plugins.jbossas7.ManagedASComponent cannot be cast to org.rhq.modules.plugins.jbossas7.BaseServerComponent
        at org.switchyard.rhq.plugin.SwitchYardDiscoveryComponent.discoverResources(SwitchYardDiscoveryComponent.java:67)
        at sun.reflect.GeneratedMethodAccessor29.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:305)
        ... 5 more



Version-Release number of selected component (if applicable):
JON ER5 build

How reproducible:
100%

Steps to Reproduce:
1. Install JON server, switchyard plugin, agent
2. Inventory agent
3. Perform manual discovery (agent platform right click -> Operations -> Manual autodiscovery)
Comment 2 Mike Foley 2013-11-18 16:12:55 EST
dupe ... should be in next release 

Bug 1018270 - Switchyard plugin throws errors when Managed Server on EAP6 Domain is being discovered
Comment 3 Mike Foley 2013-11-18 16:14:09 EST

*** This bug has been marked as a duplicate of bug 1018270 ***

Note You need to log in before you can comment on or make changes to this bug.