Bug 103183 - up2date fails on upgrading glibc on via mini-itx
up2date fails on upgrading glibc on via mini-itx
Status: CLOSED DUPLICATE of bug 103162
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 08:48 EDT by Paul Nasrat
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2003-08-27 08:48:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Upon trying to use up2date to upgrade XFree86 which requires a newer glibc it
selects the incorrect arch for glibc.

I have confirmed up2date will install and upgrade a non-multi arch package:

up2date lynx (install) 
up2date mutt (upgrade)

[paul@babel paul]$ uname -a
Linux babel.eridu 2.4.21-20.1.2024.2.1.nptl #1 Fri Jul 11 05:55:25 EDT 2003 i686
i686 i386 GNU/Linux

[paul@babel paul]$ rpm --qf='%{arch}\n' -q glibc
i386

[paul@babel paul]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 7
model name      : VIA Samuel 2
stepping        : 3
cpu MHz         : 533.357
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu de tsc msr cx8 mtrr pge mmx 3dnow
bogomips        : 1064.96



Version-Release number of selected component (if applicable):
up2date-3.9.14-2

How reproducible:
Always

Steps to Reproduce:
1. Install severn on mini-itx platform
2. Subscribe to rhn
3. Ensure that redhat 9.0.93 updates subchannel is subscribed to in rhn
3. run up2date glibc

    

Actual Results:  Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1148, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 747, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1014, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 76, in run
    self.__installPackages()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 145, in
__installPackages
    self.kernelsToInstall = up2date.installPackages(self.packagesToInstall,
self.rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 717, in installPackages
    runTransaction(ts, rpmCallback, rollbacktrans = rollbacktrans)
  File "/usr/share/rhn/up2date_client/up2date.py", line 622, in runTransaction
    rpmUtils.runTransaction(ts,rpmCallback, transdir)
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 482, in runTransaction
    "Failed running transaction of  packages: %s") % errors, deps=rc)
up2date_client.up2dateErrors.TransactionError: RPM  error. The message was:
Failed running transaction of  packages:
('package glibc-2.3.2-71 is intended for a i686 architecture', (0, 'i686', 0L))


Expected Results:  i386 package should be selected and upgraded.  The fact it
fails on i686 is good, as it definitely shouldn't install the wrong arch.
Comment 1 Paul Nasrat 2003-08-27 08:52:56 EDT

*** This bug has been marked as a duplicate of 103162 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.