Bug 1031836 - Excluding ARM from the arches broke compose of many ARM images for Fedora 20 Final TC1
Excluding ARM from the arches broke compose of many ARM images for Fedora 20 ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pexpect (Show other bugs)
20
arm Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-11-18 17:52 EST by Adam Williamson
Modified: 2013-11-23 22:52 EST (History)
3 users (show)

See Also:
Fixed In Version: python-pexpect-3.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 22:52:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-11-18 17:52:52 EST
In building Fedora 20 Final TC1, we found a lot of ARM images (any containing yumex) failed to compose due to a dependency issue:

Unable to create appliance : Failed to build transaction : yumex-3.0.13-1.fc20.noarch requires python-pexpect

I traced this down to https://admin.fedoraproject.org/updates/FEDORA-2013-15870/python-pexpect-2.5.1-11.fc20 , which was submitted two months ago but only went stable on 2013-11-14. It excluded ARM, so once that build was pushed stable, python-pexpect no longer existed in the F20 ARM repos, and the yumex dependency issue was introduced.

https://admin.fedoraproject.org/updates/FEDORA-2013-21289/python-pexpect-3.0-1.fc20 should fix this - i.e. the package is available for ARM again in that build. We should pull that build into the F20 Final TC2 compose to address this issue.

Proposing as a freeze exception issue: this didn't actually prevent the compose of any release blocking ARM images, minimal and KDE were both built, but many others were blocked by this issue.
Comment 1 Fedora Update System 2013-11-18 17:55:20 EST
python-pexpect-3.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-21289/python-pexpect-3.0-1.fc20
Comment 2 Adam Williamson 2013-11-20 15:17:22 EST
Discussed at 2013-11-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-20/f20-blocker-review.2013-11-20-17.00.log.txt . Accepted as a freeze exception issue, obviously, we want all our images to compose.
Comment 3 Fedora Update System 2013-11-23 22:52:02 EST
python-pexpect-3.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.