Bug 1031849 - Drop requirement on python-webob1.0
Drop requirement on python-webob1.0
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Unspecified
high Severity low
: rc
: 4.0
Assigned To: Alan Pevec
Ofer Blaut
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 19:45 EST by Lon Hohberger
Modified: 2016-04-26 10:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-10.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:37:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
apevec: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2013-11-18 19:45:01 EST
Description of problem:

Python-webob1.0 is antiquated and superseded by python-webob1.2.  Upstream, the requirements.txt has '>= 1.2.3 < 1.3', so openstack-neutron should not require it any more.

Version-Release number of selected component (if applicable): openstack-neutron-2013.2-9.el6ost

How reproducible: 100%

Steps to Reproduce:
1. yum install -y openstack-neutron
2. rpm -q --whatrequires python-webob1.0

Actual results: python-neutron requires python-webob1.0

Expected results: No package requires python-webob1.0/
Comment 4 Ofer Blaut 2013-11-27 13:45:30 EST
verified

python-webob1.2   is used 
 

[root@puma04 ~]# rpm -q --whatrequires python-webob1.0
no package requires python-webob1.0

[root@puma04 ~]# rpm -qR openstack-neutron
/bin/bash  
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/usr/bin/python  
chkconfig  
chkconfig  
config(openstack-neutron) = 2013.2-10.el6ost
dnsmasq  
dnsmasq-utils  
initscripts  
initscripts  
openstack-utils  
python-keystone  
python-neutron = 2013.2-10.el6ost
python-pbr  
python-pyudev  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
shadow-utils  
rpmlib(PayloadIsXz) <= 5.2-1
[root@puma04 ~]# rpm -qR python-neutron
MySQL-python  
python(abi) = 2.6
python-alembic  
python-anyjson  
python-babel  
python-eventlet  
python-greenlet  
python-httplib2  
python-iso8601  
python-jinja2-26  
python-keystoneclient  
python-lxml  
python-netaddr  
python-neutronclient  
python-oslo-config >= 1:1.2.0
python-paste-deploy1.5  
python-qpid  
python-routes1.12  
python-sqlalchemy0.7  
python-webob1.2  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
sudo  
rpmlib(PayloadIsXz) <= 5.2-1
Comment 8 errata-xmlrpc 2013-12-19 19:37:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.