Bug 1031856 - rhc tools doesn't show the latest cartridge Display-Name
rhc tools doesn't show the latest cartridge Display-Name
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
All All
unspecified Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 20:10 EST by Vojtech Vitek
Modified: 2015-05-14 20:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 02:09:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vojtech Vitek 2013-11-18 20:10:18 EST
I changed the Display-Name of the cartridge manifest file from:
> Display-Name: Old name
to:
> Display-Name: New name

Description of problem:

Having both cartridge versions installed in the system, rhc tools read the 'Old name' first and shows it instead of the 'New name'.
Comment 2 Vojtech Vitek 2013-11-20 13:32:02 EST
# New Display-Name 0.0.9 cartridge version:
$ diff /var/lib/openshift/.cartridge_repository/redhat-php/0.0.{8,9}/metadata/manifest.yml
> --- /var/lib/openshift/.cartridge_repository/redhat-php/0.0.8/metadata/manifest.yml	2013-11-13 21:42:26.000000000 -0500
> +++ /var/lib/openshift/.cartridge_repository/redhat-php/0.0.9/metadata/manifest.yml	2013-11-20 13:23:42.650323361 -0500
> @@ -1,7 +1,7 @@
>  ---
>  Name: php
>  Cartridge-Short-Name: PHP
> -Display-Name: PHP 5.3
> +Display-Name: New PHP 5.3
>  Description: ! 'PHP is a general-purpose server-side scripting language originally
>    designed for Web development to produce dynamic Web pages. Popular development frameworks
>    include: CakePHP, Zend, Symfony, and Code Igniter.'
> @@ -9,7 +9,7 @@ Version: '5.3'
>  License: The PHP License, version 3.0
>  License-Url: http://www.php.net/license/3_0.txt
>  Vendor: php.net
> -Cartridge-Version: 0.0.8
> +Cartridge-Version: 0.0.9
>  Compatible-Versions:
>  - 0.0.7
>  Cartridge-Vendor: redhat

# Clear Broker/mcollective cache
$ service ruby193-mcollective restart
$ oo-admin-broker-cache -c

# Check for both versions and see what Display-Name is printed by the rhc tools:
$ { oo-admin-cartridge -l; rhc cartridge-list; } | grep php
> (redhat, php, 5.3, 0.0.8)
> (redhat, php, 5.3, 0.0.9)
> php-5.3             PHP 5.3                                     web

                      ^^^^ Should be "New PHP 5.3"
Comment 3 Abhishek Gupta 2013-12-04 14:54:51 EST
I am not able to reproduce this bug.

I tested this by modifying the php cartridge Display-Name and bumping up the Cartridge-Version and was able to see the updated display name in the php cartridge being returned by the CLI tools.

Also, I tested with changing the Display-Name in the Version-Overrides section of the zend cartridge and still was able to see the updated display name in the output of the CLI cartridge list command.
Comment 4 zhaozhanqi 2013-12-05 02:09:51 EST
I tested this issue on devenv_4098, also can not reproduce this bug. 

@Vojtech Vitek I'm not sure if you are testing this on multi-node env. if so, you need to modify manifest.yml in all nodes. Thus the result will be we expected.
Comment 5 Vojtech Vitek 2013-12-05 17:49:30 EST
@zhaozhanqi I tested this in the one machine node/broker environment.

Note You need to log in before you can comment on or make changes to this bug.