Bug 1031941 - [INT] rhc operations failed with error 16550: "not authorized for query on openshift_broker.cloud_users" on INT
[INT] rhc operations failed with error 16550: "not authorized for query on op...
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 03:07 EST by Yan Wei
Modified: 2015-05-14 20:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
using RHEL 6.3 rhc version 1.16.9 int.openshift.redhat.com
Last Closed: 2013-11-21 13:58:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Wei 2013-11-19 03:07:36 EST
Description of problem:
All action didn't work unexpectedly and suddenly.

Version-Release number of selected component (if applicable):
rhc 1.16.9

How reproducible:
deduce it as a online environment problem, influenced to many person's account already.

Steps to Reproduce:
1.
2.
3.

Actual results:

============================================================================
Unable to complete the requested operation due to: The operation: #<Moped::Protocol::Query
  @length=126
  @request_id=78
  @response_to=0
  @op_code=2004
  @flags=[]
  @full_collection_name="openshift_broker.cloud_users"
  @skip=0
  @limit=-1
  @selector={"$query"=>{"login"=>"XXX@redhat.com"}, "$orderby"=>{:_id=>1}}
  @fields=nil>
failed with error 16550: "not authorized for query on openshift_broker.cloud_users"

See https://github.com/mongodb/mongo/blob/master/docs/errors.md
for details about this error..
Reference ID: 185039e7a3aa54ad5a8979af9e31ca00
=============================================================================
Expected results:
login successfully

Additional info:
Comment 1 Jianwei Hou 2013-11-19 03:25:22 EST
The environment is INT
And I'm having the same problem, do any operation(eg: rhc account) and this error is returned. Looks like something is going wrong with the mongodb.

% rhc account -l jhou@redhat.com --server int.openshift.redhat.com
Unable to complete the requested operation due to: The operation: #<Moped::Protocol::Query
  @length=178
  @request_id=43
  @response_to=0
  @op_code=2004
  @flags=[:slave_ok]
  @full_collection_name="openshift_broker.authorizations"
  @skip=0
  @limit=-1
  @selector={"$query"=>{"token"=>"a8141d80e2a5bde976e86951df3f25f642675a8fba31acb0e66649f7408d093a"}, "$orderby"=>{:_id=>1}}
  @fields=nil>
failed with error 16550: "not authorized for query on openshift_broker.authorizations"

See https://github.com/mongodb/mongo/blob/master/docs/errors.md
for details about this error..
Reference ID: c43be8e9fb301c8f0686105a0d07e785
Comment 2 Peter Ruan 2013-11-21 13:58:01 EST
just tried it and it worked for me.

[pruan@homer-linux <DEV> features]# rhc domain show --server=int.openshift.redhat.com -l pruan@redhat.com -p vostok08
Domain urbozt (owned by pruan@redhat.com)
-----------------------------------------
  Created:            Nov 08  3:34 PM
  Allowed Gear Sizes: small, medium, large

  php @ http://php-urbozt.int.rhcloud.com/ (uuid: 528e572d6cec0e96a0000a8d)
  -------------------------------------------------------------------------
    Domain:     urbozt
    Created:    10:55 AM
    Gears:      1 (defaults to small)
    Git URL:    ssh://528e572d6cec0e96a0000a8d@php-urbozt.int.rhcloud.com/~/git/php.git/
    SSH:        528e572d6cec0e96a0000a8d@php-urbozt.int.rhcloud.com
    Deployment: auto (on git push)

    php-5.3 (PHP 5.3)
    -----------------
      Gears: 1 small

You have 1 application in your domain.
[pruan@homer-linux <DEV> features]# rhc account --server=int.openshift.redhat.com -l pruan@redhat.com -p vostok08
Login pruan@redhat.com on int.openshift.redhat.com
--------------------------------------------------
  ID:                 527ad8f003ef64917f000011
  Plan:               Free
  Gears Used:         1
  Gears Allowed:      20
  Domains Allowed:    1
  Allowed Gear Sizes: small, medium, large
  SSL Certificates:   no

Note You need to log in before you can comment on or make changes to this bug.