Bug 1031985 - Multicast messages can be replayed to new node
Multicast messages can be replayed to new node
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER1
: 6.3.0
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks: 1092056
  Show dependency treegraph
 
Reported: 2013-11-19 05:11 EST by Radim Vansa
Modified: 2015-01-26 09:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-26 09:05:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3731 Critical Resolved Multicast messages can be replayed to new node 2017-01-12 04:18 EST

  None (edit)
Description Radim Vansa 2013-11-19 05:11:04 EST
Messages that target all current members are sent as multicast messages.
However, these retransmissions can be replayed on new nodes that have just joined the cluster.
This can result for example in execution of already completed transaction on the new node, causing possible data inconsistency for those entries which are owned by the new node in backup way - the replayed transaction sequence authoritatively overwrites them.

The node should remember the first topologyId it has seen and do not execute any commands that have lower topologyId.
Comment 1 JBoss JIRA Server 2013-11-19 05:15:41 EST
Dan Berindei <dberinde@redhat.com> made a comment on jira ISPN-3731

Before my fix for ISPN-3670, commands received before the initial topology used to be ignored. Of course, this caused other problems, because some commands shouldn't be ignored (the ones that were sent explicitly to the joiner, because some nodes already see it as a member of the write CH).

Note You need to log in before you can comment on or make changes to this bug.