Bug 1031997 - Prevent auto-reconnect on secrets failure until agents change
Prevent auto-reconnect on secrets failure until agents change
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
20
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 05:35 EST by Martin
Modified: 2014-09-14 20:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: kde-plasma-nm-0.9.3.2-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-08 02:56:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl (670.93 KB, text/x-log)
2013-11-19 05:35 EST, Martin
no flags Details

  None (edit)
Description Martin 2013-11-19 05:35:47 EST
Created attachment 826006 [details]
journalctl

Description of problem:
Network Manager loops before login to KDE session

Version-Release number of selected component (if applicable):
NetworkManager-0.9.9.0-17.git20131003.fc20.x86_64
kde-plasma-nm-0.9.3.1-6.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. Add new password secured wireless connection
2. Reboot
3. Login to KDE

Actual results:
login to KDE session is delayed by cca 30 seconds
lot of NetworkManager messages in journalctl, see attached dump
after login KDE asks for password for already configured wireless connection, in meantime kde-plasma-nm announces successful connection activation via notification

Expected results:
login to KDE session without delays
no NetworkManager flood in journalctl
no KDE password dialog for already configured wireless connections 

Additional info:
If I check "All users may connect to this network", problem is workarounded.
Comment 1 Jan Grulich 2013-11-19 06:14:18 EST
I'm not sure whether we can do something with your problem, because NetworkManager doesn't get the password until you unlock your KWallet and probably keeps trying to get the password from our secret agent. One solution could be to wait (in the case when your connection has stored secrets in some secret agent) until the secret agent tells to NM something like "I'm ready and you can asks for secrets".
Comment 2 Martin 2013-11-19 13:06:33 EST
I don't have KWallet locked. Anyway, this is regression from behaviour in F19.
Comment 3 Dan Williams 2013-11-19 13:42:43 EST
NetworkManager doesn't actually operate differently here in the core than it did in Fedora 19; if the secret agent isn't available, then it will retry the connection a few times until one is.

What NetworkManager should do is if the connection fails because no secrets are available, suppress retrying the connection until an agent appears or disappears.
Comment 4 Florian Hubold 2013-12-22 14:02:28 EST
FWIW, I'm encountering the exact same issue since F20. Upgrade or fresh installation doesn't matter.

The query for a password should not block the KDE startup for 20-30 seconds uselessly. This is definitely a regression to F19, not sure how that wasn't caught by QA.

network manager plasmoid should not try to query kwallet when kwallet is not available yet AND it should not block kde login until it has timed out once (those are probably the 30 seconds delay).

Delay can be easily reproduced also by creating a connection, setting it to auto-connect and then logging out, wiping ~/.kde/ and then logging in again. [You'll sometimes see a notification box on splash screen that says "password required"] After ~30 seconds login will continue, and the normal password dialog can be seen.

I should add that my kwallet password is an empty one.


WORKAROUND / POSSIBLE CAUSE & SOLUTION:

What works for me when creating a new connection is disable automatic connect, then logout, login, connect once and click on "always allow" when kded requests access to kwallet.

Probably the issue comes from kded not requesting access to kwallet when initially creating a new connection, and the dialog will only be shown during next KDE startup when it tries to connect, where it cannot be seen nor acknowledged. After login the kded/kwallet authorization dialog will not reappear.

Please fix.
Comment 5 Fedora Update System 2014-01-02 09:07:10 EST
kde-plasma-nm-0.9.3.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kde-plasma-nm-0.9.3.2-2.fc20
Comment 6 Fedora Update System 2014-01-03 03:39:49 EST
Package kde-plasma-nm-0.9.3.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-nm-0.9.3.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0081/kde-plasma-nm-0.9.3.2-2.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-01-03 18:26:02 EST
Package kde-plasma-nm-0.9.3.2-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-nm-0.9.3.2-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0081/kde-plasma-nm-0.9.3.2-3.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-01-08 02:56:06 EST
kde-plasma-nm-0.9.3.2-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.