Bug 1032002 - Status of the volume in activities column after remove-brick stop should be in sync with gluster CLI output
Status of the volume in activities column after remove-brick stop should be i...
Status: CLOSED CANTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ramesh N
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 05:46 EST by RamaKasturi
Modified: 2015-05-12 14:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-27 07:56:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2013-11-19 05:46:45 EST
Description of problem:
The icon shown in the activities column of the volume after remove-brick stop should reflect the actual status of the activity and should be in sync with the gluster CLI output.

Version-Release number of selected component (if applicable):

rhsc-2.1.2-0.24.master.el6_5.noarch
How reproducible:
Always

Steps to Reproduce:
1. Go to Volumes tab and select a volume from the list
2. Start remove-brick by clicking the "Remove" menu option
3. Wait for sometime and click the "Stop" from drop down menu option in activities column from either bricks/volumes sub tab.

Actual results:
The activities column icon changes to stopped whereas the activities got finished by the time stop was fired.

Expected results:
If the activity got finished by the time stop was fired, the same should be reflected in volume and brick activities column as well.


Additional info:
Comment 2 Dusmant 2013-11-19 11:36:21 EST
We should try to fix it, but if the infrastructure is not there to handle this situation, then we will remove this out of Corbett list. For the time being, i am keeping it in Corbett.
Comment 3 Ramesh N 2013-11-20 03:28:51 EST
Activity column for remove-brick and GLUSTER CLI remove-brick output cannot be in sync because Gluster CLI says completed even if we stop the remove-brick operation after migration is completed. But in console we are marking this task
as Aborted once the user calls retain after migration.

   One possible solution is that we can show the remove-brick summary status in 
remove brick status dialog as Aborted, if remove-brick is either stoped/retained.
Comment 4 Dusmant 2013-12-03 05:22:53 EST
As mentioned in my previous comment, i am removing this bug from the Corbett list. Current infrastructure is not capable of supporting this.
Comment 5 Sahina Bose 2015-03-27 07:56:22 EDT
Closing as per comment 4

Note You need to log in before you can comment on or make changes to this bug.