Bug 1032019 - An event message should be displayed when a brick is retained.
An event message should be displayed when a brick is retained.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Ramesh N
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 06:47 EST by RamaKasturi
Modified: 2015-05-13 12:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 03:04:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21909 None None None Never

  None (edit)
Description RamaKasturi 2013-11-19 06:47:47 EST
Description of problem:
Event message should be generated when a brick is retained.

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.24.master.el6_5.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a distribute volume and start it.
2. Select a brick and start removing it.
3. Once data migration completes, click on retain.

Actual results:
Event message does not get displayed,when a brick is retained.

Expected results:
Event message should be generated when a brick is retained.

Additional info:
Comment 2 RamaKasturi 2013-12-02 00:43:04 EST
No event message gets generated in the UI when a brick is retained.
Comment 3 Dusmant 2013-12-02 00:45:57 EST
Not even the STOP event message is generated. Because the underneath msg for retain is also Stop.

We need to retriage this bug.
Comment 4 Ramesh N 2013-12-10 04:49:01 EST
There is not differentiation between stop remove brick and retain brick in engine side. There is only stop remove brick command which is getting called in both the cases. Hence we will show the same event message "stopped removing bricks from gluster volume V1" in both the cases.
Comment 5 RamaKasturi 2013-12-13 03:58:56 EST
Verified in build cb11 (rhsc-2.1.2-0.27.beta.el6_5.noarch). 

When bricks are retained from UI, the following event message gets displayed.
"Stopped removing bricks from Volume <volName>"

Attaching the screenshot for the same.
Comment 6 Ramesh N 2014-01-03 03:38:07 EST
Doc Text is not required  as its a new feature and we already have an RFE
Comment 8 errata-xmlrpc 2014-02-25 03:04:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.