Bug 103202 - Intermittent hangup (stall) on smbfs mount
Intermittent hangup (stall) on smbfs mount
Status: CLOSED DUPLICATE of bug 90036
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brian Brock
:
: 106026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 13:57 EDT by ben mohilef
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ben mohilef 2003-08-27 13:57:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When mounting samba shares, the mount program intermittently hangs up after
mounting a share.  A "Cntl-C" will clear the hangup and the share is mounted,
however, this command obviously wil not work reproducibly in shell scripts. This
is true in both an i686 system and a dual athlon smp system. Both systems worked
properly before upgrade from RH 8.0 to RH 9.0. 

This problem has been reported by several others. Incidents were reported in
Google and in the RH Digest. References: 
   1. Samba With RH 9.0 (redhat digest 8260)
   2.  Re: Samba With RH 9.0 (redhat digest 8282)
   3.
http://groups.google.com/groups?q=bug+mount+linux+smbfs&start=10&hl=en&lr=&ie=UTF-8&scoring=d&selm=3ec4e3ee%240%2418200%2491cee783%40newsreader01.highway.telekom.at&rnum=20
   4. 
http://groups.google.com/groups?q=bug+mount+linux+smbfs&hl=en&lr=&ie=UTF-8&scoring=d&selm=3f04587e%240%2443849%2439cecf19%40news.twtelecom.net&rnum=9


Version-Release number of selected component (if applicable):
kernel 2-4.20 (all revs 08 through 20). SMP as well as i686. 

How reproducible:

Always. 2 boxes have this problem, but windoze and RH 7.1 thru 8.0 boxen have NO
similar problem. 

Steps to Reproduce:
1. mount -t smbfs \\somebox\ashare\ ... etc
2. mount -t smbfs \\somebox\ashare\ ... etc
3. mount -t smbfs \\somebox\ashare\ ... etc
It never consistently succeeds four times in a row
    

Expected Results:  mount should return in all cases, rather than in 1 to 3 of
four tries.

Additional info:

strace is fair to middling useless here, since there is no difference between
the successful and unsucessful attempts except that the successful oners
complete normally.
Comment 1 David Lawrence 2003-10-02 15:05:49 EDT
*** Bug 106026 has been marked as a duplicate of this bug. ***
Comment 2 David Lawrence 2003-10-02 16:01:06 EDT
I set this up in our labs. The only time I get the hang is trying to mount a
share from our Windows2000 machine. I do not get the hang when performing the
same task against a RHL8 machine with samba enbled. So something is diff with
the Windows box. 
Comment 3 Zenon Panoussis 2003-10-03 06:41:37 EDT
If I understand you correctly, you are mounting a samba share from a windoze
machine. If that is so, it's the opposite of what I do; I am using the samba
client to mount a windows share on the linux machine. 

*

Searching Google for mentions of this problem, I found several. All of them,
without exception, occur on Redhat 9 installations (I found no complaints from
users of other distributions). The earliest reports I found are dated June this
year. Thus, it appears that this is a Redhat-specific problem and that it was
introduced with some update after the original RHL9 release.

The samba rpm that comes with redhat is heavily patched. In an attempt to figure
whether the patches could cause the problem, I compiled and installed
samba-3.0.0-2.rpm from the tarball at samba.org . The problem still persists,
but has become intermittent. It seems that the very first time mount is run
(with correct parametres) it always returns exit code 0, while on subsequent
attempts it sometimes returns an exit code and sometimes not. I also got the
impression that waiting more than a minute between attempts increases the
chances of getting an exit code, but that's really unreliable statistics.

In any case, unless some of the redhat patches to samba 2.2.7 have found their
way into the samba 3.0.0 source, we might conclude that the problem is not in
samba itself. That would leave mount and its cousins as the suspects. 

Looking at the RHL9 updates directory, I see a samba release in early July but
no update of mount or anything directly related to it. Then again, if the
problem was introduced with the samba release in July, we wouldn't have
complaints already in June. Was there perhaps a samba update in June that has
now disappeared from the updates mirrors? 

The only other possible culprit I see is bash. It was updated in early June and
it is in a position to cause problems with exit code handling. I'll downgrade my
bash and see what happens. 



Comment 4 ben mohilef 2003-10-05 14:39:40 EDT
On my RH 9.0 systems, the intermittent failure occurs mounting shares on both 
windoze machines of the Win 2K and Me variety and on other 
Linux boxen of the RH 7.1 and 8.0 variety. 

Someone ( I don't recall who ) sent me a workaround which works 
flawlessly. The workaround may help in discerning the cause:

export LD_ASSUME_KERNEL=2.4.1
/usr/sbin/smbmount //WinPC/share  /unixmount 
username=whomever,uid=somenumber,gid=somenumber,dmask=770

Comment 5 Zenon Panoussis 2003-10-05 14:50:51 EDT
Downgrading bash (see comment #3) didn't help. 

This bug is a dupe to #89589. Comment #11 at #89589 contains a workaround, one
line of code added to source/clients/smbmount.c . I tested it and it works. 
Comment 6 Jay Fenlason 2003-10-06 17:46:17 EDT

*** This bug has been marked as a duplicate of 90036 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:58:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.