Bug 1032020 - [RHS-C] No error pop-up is seen while trying to stop the volume during a remove brick operation [NEEDINFO]
[RHS-C] No error pop-up is seen while trying to stop the volume during a remo...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity medium
: ---
: RHGS 3.1.0
Assigned To: Karnan
RamaKasturi
:
Depends On:
Blocks: 1202842
  Show dependency treegraph
 
Reported: 2013-11-19 06:53 EST by Prasanth
Modified: 2016-11-13 19:04 EST (History)
12 users (show)

See Also:
Fixed In Version: rhsc-3.1.0-57
Doc Type: Bug Fix
Doc Text:
Previously, there was no error message displayed if a user tries to stop a volume when the remove-brick operation was in progress. With this fix, "Error while executing action: Cannot stop Gluster Volume. Rebalance operation is running on the volume <vol_name> in cluster <cluster_name>" error message is displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 01:25:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
divya: needinfo? (kchidamb)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 28472 master MERGED engine:fail stop volume if remove brick is running Never

  None (edit)
Description Prasanth 2013-11-19 06:53:49 EST
Description of problem:

No error pop-up is seen when trying to stop the volume while remove brick operation is in progress.


Version-Release number of selected component (if applicable): cb8 build
Red Hat Storage Console Version: 2.1.2-0.24.master.el6_5


How reproducible: 100%


Steps to Reproduce:
1. Create a distribute volume with 2 bricks and start it
2. Mount the volume from a client and write some data
3. Start removing 1 brick from the UI with migrate data ON
4. When the data migration is in progress and icon appears, try to stop the volume

Actual results: No error pop-up seen in the UI. Only the following message appears in Events which doesn't provide the reason for the failure:

---
Could not stop Gluster Volume disvol1.
---


Expected results: Proper error pop-up should be given when the user tries to STOP the volume.

From CLI following error message is seen:

---
[root@vm11 ~]# gluster volume stop disvol1
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
volume stop: disvol1: failed: rebalance session is in progress for the volume 'disvol1'
---

When you try to stop the volume when a rebalance operation is in progress, following error pop-up is seen as well:

---
Error while executing action: Cannot stop Gluster Volume. Rebalance is running on the volume disvol1 in cluster Cluster-CB8.
---

Additional info:
Comment 1 RamaKasturi 2015-05-27 07:40:26 EDT
Verified and works fine with build rhsc-3.1.0-0.57.master.el6.noarch.

when user tries to stop a volume while remove brick operation is in progress UI dispalys a message which says "Error while executing action: Cannot stop Gluster Volume. Remove brick operation is running on the volume <vol_name> in cluster <cluster_name>"

When rebalance is going on and user tries to stop the volume , UI displays the following message "Error while executing action: Cannot stop Gluster Volume. Rebalance operation is running on the volume <vol_name> in cluster <cluster_name>"
Comment 2 Divya 2015-07-26 07:04:46 EDT
Karnan,

Please review and sign-off the edited doc text.
Comment 4 errata-xmlrpc 2015-07-29 01:25:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1494.html

Note You need to log in before you can comment on or make changes to this bug.