Bug 1032033 - Sort unavailable & alerted resources portlet - parent first
Sort unavailable & alerted resources portlet - parent first
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity medium
: DR01
: JON 3.3.0
Assigned To: Libor Zoubek
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 07:19 EST by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:05:01 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-11-19 07:19:02 EST
Description of problem:

On our dashboard, there is by default portlet called "Alerted or unavailable resources". It's by default set to display only 20 resources.


Version-Release number of selected component (if applicable):
JON 3.2.ER5

How reproducible: always


Steps to Reproduce:
1. have EAP6 imported and available
2. stop it
3. go to dashboard and look at above portlet

Actual results:

It shows lot's of resources, direct or undirect children of your EAP6 server. It does not show EAP6 server itself though. When you see this (assuming you don't know you just stopped your server) you have to navigate to any of those resources and find out .. "ah that JMS factory is down is because server is down"


Expected results: portlet should show resources with shortest inventory path (platforms first, servers, services, then rest of resources) so user does not have to navitage. 


Additional info:
Comment 1 Libor Zoubek 2014-05-06 05:48:16 EDT
in master
commit e429846dd715e0615e27eb1aa7e599cc508481a6
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Tue May 6 11:41:30 2014 +0200

    [BZ 1032033] - Sort unavailable & alerted resources portlet - parent first

    Unavailable and alerted resources are now ordered by 1. alert count, 2.
    ancestry.length 3. resource name - so when for example platform is DOWN it
    will show up in portlet before it's children
Comment 2 Jay Shaughnessy 2014-05-13 12:05:14 EDT
commit 89d4f63a8017d4ee4acd20b3af3129f71086c980
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Tue May 13 12:04:14 2014 -0400

  Fix a few issues with the prior commit for this issue (e429846dd715e0)
  - needed to be able to handle null ancestry (for platforms, which can
    be problem resources like anything else). This fix fixed the test
    failures as well.
  - Restore the previous ProblemResourceComposite constructor since this
    class *is* exposed remotely.  Add new entry for new constructor.
Comment 3 Simeon Pinder 2014-07-31 11:52:36 EDT
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993

Note You need to log in before you can comment on or make changes to this bug.