Bug 1032035 - [RFE]re-write auto install function for the cim plugin
[RFE]re-write auto install function for the cim plugin
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.1
Assigned To: Ryan Barry
bugs@ovirt.org
node
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 07:29 EST by haiyang,dong
Modified: 2014-04-30 07:29 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-30 07:29:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20641 master MERGED re-write auto install function for the cim plugin Never

  None (edit)
Description haiyang,dong 2013-11-19 07:29:26 EST
Description of problem:
Due to cim as plugin package, so need remove auto install configuration functions for the cim plugin from ovirt-init-functions.sh of ovirt-node base iso.
Like "snmp_autoinstall.py" and "puppet_autoinstall.py", re-write auto install function for the cim plugin into "cim_autoinstall.py" to achieve only add 
cim auto install configuration functions for ovirt-node when installing cim plugin package into base iso 


Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.1222.el6.iso
ovirt-node-plugin-cim-3.1.0-0.999.20131115083921git237de0c.el6.noarch.rpm

How reproducible:
100%

Steps to Reproduce:

Actual results:


Expected results:

Additional info:
Comment 1 Fabian Deutsch 2013-11-28 10:22:47 EST
Ryan, can you please review the pending patch
Comment 2 Sandro Bonazzola 2014-02-04 07:39:20 EST
re-targeting to 3.3.4 since the attached patch is not merged.
Comment 3 Sandro Bonazzola 2014-03-04 06:02:16 EST
this is an automated message.
Moving remaining open bugs targeting 3.3.4 to 3.4.1.
If relevant for 3.3-stable, please reset target version accordingly.

Note You need to log in before you can comment on or make changes to this bug.