Bug 1032041 - [QE] (6.3.0) NPE in cli is thrown when using preserve, override without parameter
[QE] (6.3.0) NPE in cli is thrown when using preserve, override without param...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Patching (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: DR2
: EAP 6.3.0
Assigned To: Emanuel Muckenhuber
Jan Martiska
Russell Dickenson
:
: 1032095 1065536 1070330 (view as bug list)
Depends On:
Blocks: 1065874
  Show dependency treegraph
 
Reported: 2013-11-19 07:44 EST by Martin Simka
Modified: 2015-02-01 18:05 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2536 Minor Resolved NPE in cli is thrown when using preserve, override without parameter 2016-02-03 09:16 EST

  None (edit)
Description Martin Simka 2013-11-19 07:44:16 EST
Description of problem:
NPE in cli is thrown when using preserve, override without parameter

Version-Release number of selected component (if applicable):
EAP 6.2.0.CR2

Steps to Reproduce:
1. in jboss-cli run command patch apply <path_to_patch> --preserve or patch apply <path_to_patch> --override

Actual results:
java.lang.NullPointerException
        at org.jboss.as.patching.cli.PatchHandler.createPatchOperationBuilder(PatchHandler.java:353)
        at org.jboss.as.patching.cli.PatchHandler.doHandle(PatchHandler.java:246)
        at org.jboss.as.cli.handlers.CommandHandlerWithHelp.handle(CommandHandlerWithHelp.java:86)
        at org.jboss.as.cli.impl.CommandContextImpl.handle(CommandContextImpl.java:600)
        at org.jboss.as.cli.impl.CommandContextImpl.handleSafe(CommandContextImpl.java:616)
        at org.jboss.as.cli.impl.CommandContextImpl.interact(CommandContextImpl.java:1204)
        at org.jboss.as.cli.impl.CliLauncher.main(CliLauncher.java:263)
        at org.jboss.as.cli.CommandLineMain.main(CommandLineMain.java:34)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.jboss.modules.Module.run(Module.java:292)
        at org.jboss.modules.Main.main(Main.java:455)


Expected results:
Error message saying that preserve and override requires path as parameter
Comment 1 Carlo de Wolf 2013-11-21 06:15:47 EST
*** Bug 1032095 has been marked as a duplicate of this bug. ***
Comment 2 JBoss JIRA Server 2013-12-03 09:05:20 EST
Alexey Loubyansky <alex@jboss.org> updated the status of jira WFLY-2536 to Resolved
Comment 3 JBoss JIRA Server 2013-12-03 09:05:20 EST
Alexey Loubyansky <alex@jboss.org> made a comment on jira WFLY-2536

This was fixed and merged https://github.com/wildfly/wildfly/commit/30cd3c084b575589fcda8005897f4c18a696f66d
Comment 4 Emanuel Muckenhuber 2014-02-24 10:52:49 EST
PR: https://github.com/jbossas/jboss-eap/pull/965
Comment 5 Emanuel Muckenhuber 2014-02-27 05:46:59 EST
*** Bug 1070330 has been marked as a duplicate of this bug. ***
Comment 6 Emanuel Muckenhuber 2014-02-27 05:52:23 EST
*** Bug 1065536 has been marked as a duplicate of this bug. ***
Comment 7 Jan Martiska 2014-03-06 06:20:45 EST
Verified in EAP 6.3.0.DR2.

Note You need to log in before you can comment on or make changes to this bug.