Bug 1032045 - [RFE] libvirt enhanced notifications (diskspace on hdd with VM image)
[RFE] libvirt enhanced notifications (diskspace on hdd with VM image)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 1073766
  Show dependency treegraph
 
Reported: 2013-11-19 07:57 EST by Frantisek Reznicek
Modified: 2015-11-15 20:15 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1073766 (view as bug list)
Environment:
Last Closed: 2013-12-18 13:49:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Reznicek 2013-11-19 07:57:07 EST
Description of problem:

[RFE] libvirt enhanced notifications (diskspace on hdd with VM image)

I recently ran into situation when libvirt was stopping one VM for unknown reason. There was no message neither in /var/log/messages nor in libvirt log file.

It was finally caused by fact that the VM I was starting had sparse file image and there was no diskspace, so qemu-kvm was not able to write data into VM image.

I believe it is needed to inform customer why VM was internally stopped (not by user) or more generally, it would be great to have improved virtualization notifications about similar events, both in libvirt and also in virt-manager.

Version-Release number of selected component (if applicable):
N/A (libvirt-0.10.2-18.el6_4.15.x86_64 libvirt-0.10.2-29.el6.x86_64)

How reproducible:
N/A (100%)

Steps to Reproduce:
N/A
Actual results:
Missing notifications in some situations.

Expected results:
Notifications in place.

Additional info:
Comment 2 Jiri Denemark 2013-11-19 08:39:07 EST
What do you mean "for unknown reason"? Did you try "virsh domstate --reason VM"? Libvirt should tell you why the domain was paused and it also sends an event to registered clients when this happens. Thus, I guess the only part you are missing is support for state reasons and events in virt-manager, right?
Comment 3 Frantisek Reznicek 2013-11-19 08:58:43 EST
Thanks for pointing me to `virsh domstate --reason` command

  [root@mx ima]# virsh domstate --reason r6x2
  paused (I/O error)

which clearly points to disk / image problem. Command-line users are able to see the reason.

The outstanding item is to add those notifications into virt-manager.

Thanks for quick reply.

Note You need to log in before you can comment on or make changes to this bug.