Bug 103205 - patch-rpm patch
patch-rpm patch
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul Nasrat
: FutureFeature, Patch
: 131768 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 14:29 EDT by Michael Schröder
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 08:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch-rpm patch (24.07 KB, patch)
2003-08-27 14:30 EDT, Michael Schröder
no flags Details | Diff

  None (edit)
Description Michael Schröder 2003-08-27 14:29:49 EDT
Adds patch-rpm support to rpm. rpm4 port not really well tested...
Comment 1 Michael Schröder 2003-08-27 14:30:20 EDT
Created attachment 93983 [details]
patch-rpm patch
Comment 2 Jeff Johnson 2003-12-27 11:26:44 EST
The patch looks OK, but there is more to do to integrate
with other features in rpm.

I am still philosophically opposed to "patch packages",
as I think they are overly complicated and obscure for
insufficient gain. I.e. I don't believe that most packagers
can figure out how to release a patch package that upgrades
robustly everywhere.

NEEDINFO so I don't have to see the bug, while I continue
muddling what to do. At minimum, I'm willing to add patch
somewhen underneath compile time option, default off, somewhen
so that there is at least a reference rpm source code base.
Comment 3 Paul Nasrat 2005-09-27 16:52:50 EDT
*** Bug 131768 has been marked as a duplicate of this bug. ***
Comment 4 Nicholas Miell 2005-09-27 19:30:56 EDT
I once had to download a 300 MB openoffice RPM to fix a one-line problem in the
/usr/bin/ooffice shell script. That alone should be sufficient motivation for
patch RPMs.
Comment 5 Michael Schröder 2005-09-27 22:12:11 EDT
Nowadays I prefer delta rpms, as applying the delta will get you a bytewise 
identical rpm, they are thus less error prone. The disadvantage of delta rpms 
is, of course, that a delta rpm is based on exactly one version, whereas patch 
rpms can be based on multiple versions. 
Comment 6 Jeff Johnson 2006-08-04 08:09:18 EDT
for comment #4:

Speeding up downloading is no argument for patch/delta rpms.

For starters, servers everywhere would need to generate patch/delta rpm's, not going
to happen imho.

Furthermore, using rsync would have speeded up your download without the complexity
of patch/delta rpm's. A local template of OO.o rpm's (if not already available) could have
been generated by erasing and repackaging OO.o. rpm payload's have been prepared
with the equivalent of gzip --rsyncable switch for quite some years now.
Comment 7 Jeff Johnson 2007-04-03 08:57:15 EDT
Comments on whether to apply the patch or not requested at
    https://lists.dulug.duke.edu/pipermail/rpm-devel/2007-April/002240.html
Comment 8 Jeff Johnson 2007-04-03 19:07:54 EDT
Current feedback says the patch packages are unreliable and unnedded.

WONTFIX
Comment 9 Panu Matilainen 2007-06-05 08:57:54 EDT
Yeah, agreed also on rpm-maint:
https://lists.dulug.duke.edu/pipermail/rpm-maint/2007-May/000317.html

Note You need to log in before you can comment on or make changes to this bug.