Bug 1032054 - Refresh button on Monitoring/Calltime page does not move 'last 8 hour' time range
Refresh button on Monitoring/Calltime page does not move 'last 8 hour' time r...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring - CallTime, UI, Usability (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity medium
: ER04
: JON 3.3.0
Assigned To: Thomas Segismont
Filip Brychta
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 08:17 EST by Filip Brychta
Modified: 2014-12-11 09:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:00:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (115.77 KB, image/png)
2013-11-19 08:17 EST, Filip Brychta
no flags Details
screen shot (83.70 KB, application/octet-stream)
2014-09-17 05:28 EDT, Filip Brychta
no flags Details

  None (edit)
Description Filip Brychta 2013-11-19 08:17:22 EST
Created attachment 826043 [details]
screen shot

Description of problem:
This is just a usability issue but it could (and it did) increase time spent on troubleshooting the call time metrics.  

Version-Release number of selected component (if applicable):
Version :	
3.2.0.ER5
Build Number :	
2cb2bc9:225c796

How reproducible:
3/3

Steps to Reproduce:
1. Create an EAP5 instance and activate response time logging for a web appl [1]
2. Import the EAP5 instance
3. Enable call time metric on chosen Web Application Context resource (e.g. admin-console) and set collection interval to 1 minute
4. check the response time log file path on chosen Web Application Context resource r(inventory > connection page)
5. go to chosen Web Application Context resource -> Monitoring -> Calltime and set Time range to previous 8 hours (see attached screen shot)
6. generate some activity (wget 127.0.0.1:8080/admin-console)
7. check that relevant rt.log contains new lines
8. wait for the metric collection schedule interval to pass
9. press 'Refresh' button on chosen Web Application Context resource -> Monitoring -> Calltime page
10. press 'Set' button next to time range picker

[1] https://access.redhat.com/site/documentation/en-US/JBoss_Operations_Network/3.1/html/Admin_Setting_up_Monitoring_Alerts_and_Operations/rt-configuration.html#enabling-rt

Actual results:
Call time metric is NOT updated after step 9, it is updated after step 10


Expected results:
Call time metric should be updated after step 9

Additional info:
So the Refresh button actually does not refresh last 8 hours interval and it shows still the same values.
Comment 1 Libor Zoubek 2013-11-25 06:18:23 EST
I suggest completely removing the old way of setting time range from calltime view and "copy" new features already present in Metrics tab (buttons for setting time range, option for custom timerange + refresh interval).
Comment 3 Thomas Segismont 2014-08-29 07:46:53 EDT
Pull request sent
https://github.com/rhq-project/rhq/pull/115
Comment 4 Jay Shaughnessy 2014-08-29 14:29:04 EDT
Mike reviewed/merged the PR, I cherry-picked to 3.3.


master commit b08d92459c2039bafc1f904c0c0ec07b08f099d2
Merge: 8420862 f5a0afb
Author: Mike Thompson <mtho11@users.noreply.github.com>
Date:   Fri Aug 29 11:21:52 2014 -0700

    Merge pull request #115 from tsegismont/calltime_daterangeeditor



release/jon3.3.x commit 85bc070436b48bcb60f6fd17c30138eb1f8ab5ad
Author: Mike Thompson <mtho11@users.noreply.github.com>
Date:   Fri Aug 29 11:21:52 2014 -0700

    (cherry picked from commit b08d92459c2039bafc1f904c0c0ec07b08f099d2)
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>
Comment 5 Simeon Pinder 2014-09-03 16:31:58 EDT
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194
Comment 6 Filip Brychta 2014-09-04 06:38:36 EDT
Tested on
Version :	
3.3.0.ER02
Build Number :	
4fbb183:7da54e2

Buttons on Calltime tab are the same as on Metrics tab now, but the refresh still doesn't move the time range.

Expected behaviour (current behaviour on Metrics tab):
1- set 1h time range
2- set refresh interval to 1 minute

Result on Metrics tab (expected):
Time range is moved each minute to actual (latest) values..

But result on Calltime tab:
Time range is still the same after refresh.
Comment 7 Thomas Segismont 2014-09-04 12:15:35 EDT
Fixed in master

commit a19f12ba977ce551a94e23eaea28e9e2eec07d8e
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Sep 4 18:14:28 2014 +0200
    
    Missing call to #startRefreshCycle in CalltimeTableView constructor
Comment 8 Jay Shaughnessy 2014-09-11 14:36:54 EDT
This looks like the correct fix.

release/jon3.3.x commit 2f42de53f28b26b1634f9261841e8c46161ca0ef
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Sep 4 18:14:28 2014 +0200

    (cherry picked from commit a19f12ba977ce551a94e23eaea28e9e2eec07d8e)
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>
Comment 9 Simeon Pinder 2014-09-16 22:49:32 EDT
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149
Comment 10 Filip Brychta 2014-09-17 05:27:31 EDT
Current behaviour on ER3:
- time range displayed next to time range buttons is not updated after refresh
- actual data is refreshed just once, second and next refresh doesn't increase value in Count column even when you hit the web application again and again

See attached screen shot with highlighted time range
Comment 11 Filip Brychta 2014-09-17 05:28:25 EDT
Created attachment 938396 [details]
screen shot
Comment 12 Thomas Segismont 2014-09-18 08:38:11 EDT
Fixed in master

commit 945aeb12cbf8bb3e382d1d222ad54ae1f8f960cf
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Sep 18 14:36:47 2014 +0200

    Make CalltimeView implement the refresh mechanism instead of CalltimeTableView
    
    The problem was that #refresh was defined both in Table class and AutoResfresh interface.
Comment 13 Libor Zoubek 2014-09-24 08:12:18 EDT
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/5ad0d9836
time:    2014-09-24 14:11:50 +0200
commit:  5ad0d98367ab0e3d67d4cea853e2a85639c69340
author:  Thomas Segismont - tsegismo@redhat.com
message: Bug 1032054 - Refresh button on Monitoring/Calltime page does not move
         'last 8 hour' time range
         Make CalltimeView implement the refresh mechanism instead of
         CalltimeTableView
         The problem was that #refresh was defined both in Table class
         and AutoResfresh interface.
         (cherry picked from commit
         945aeb12cbf8bb3e382d1d222ad54ae1f8f960cf) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>
Comment 14 Simeon Pinder 2014-10-01 17:33:39 EDT
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959
Comment 15 Filip Brychta 2014-10-02 03:50:57 EDT
Verified on
Version :	
3.3.0.ER04
Build Number :	
99d2107:d7c537e

Note You need to log in before you can comment on or make changes to this bug.