Bug 1032069 - hosted-engine setup using cdrom image doesn't check if file is really image file
Summary: hosted-engine setup using cdrom image doesn't check if file is really image file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-19 13:44 UTC by movciari
Modified: 2016-02-23 04:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the correctness of an ISO file type was not enforced at the customization level, so the user could pass an invalid file, causing the virtual machine to refuse to boot. This error has now been fixed.
Clone Of:
Environment:
Last Closed: 2016-02-17 07:17:16 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC
oVirt gerrit 43776 master MERGED packaging: setup: validate ISO file type Never

Description movciari 2013-11-19 13:44:36 UTC
Description of problem:
when running hosted-engine --deploy, when trying to install from cdrom file, after you provide path to file setup script checks to if file exists but doesn't check if it's really iso file

setup creates VM and tries to boot it from this file, inside VM boot fails and VM boots from PXE


Version-Release number of selected component (if applicable):
is23

How reproducible:
always


Steps to Reproduce:
1. create some file that's not an iso image file (for example empty file or text file)
2. try using it as cdrom file in ovirt-hosted-engine-setup

Actual results:
setup will not fail, it will create VM and try to boot it from that file, which will result in VM booting from PXE because it couldn't boot from cdrom

Expected results:
setup should check if file is really iso file and if it's not, it should give appropriate error message and let user choose another file

Additional info:

Comment 1 Gil Klein 2016-02-17 07:17:16 UTC
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA


Note You need to log in before you can comment on or make changes to this bug.