Bug 103209 - anaconda text mode over serial console displays ugly (utf only)
anaconda text mode over serial console displays ugly (utf only)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 14:50 EDT by Tim Chambers
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 19:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot demonstrating "ugly" (25.21 KB, image/png)
2003-08-27 14:51 EDT, Tim Chambers
no flags Details

  None (edit)
Description Tim Chambers 2003-08-27 14:50:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

Description of problem:
I'm attaching a screen shot that shows just one example. I'll be glad to send
you as many more as you want. I've seen this since June, but word in our group
is that it's a known bug. I searched bugzilla and couldn't find an open bug to
cover this.

Now here comes beta2 and the serial installs are still ugly. Or am I missing
something? Is there some configuration over serial that doesn't look ugly?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect to an HP ia64 box (I tried Everest, but I've seen it on Longs Peak,
and Diablo too) with a color serial console. I tried Linux xterm, kterm, and
WinXP PuTTY -- all through console(1) through a Cyclades. I also tried
telnetting directly to the Cyclades from Linux kterm. I also connected WinXP
Hyperterminal directly to the serial port. The problem persists.
2. Boot from CD using either
LILO: linux askmethod console=ttyS0,115200n8
or
LILO: linux askmethod utf8 console=ttyS0,115200n8
(utf8 doesn't make a difference)


Actual Results:  see attached screen shot

Expected Results:  see how the VGA console looks

Additional info:
Comment 1 Tim Chambers 2003-08-27 14:51:19 EDT
Created attachment 93986 [details]
screen shot demonstrating "ugly"
Comment 2 Tim Chambers 2003-08-27 21:28:48 EDT
My mistake. This is only a bug for UTF. B&W looks great.
Comment 3 Jeremy Katz 2003-08-28 19:01:41 EDT
UTF-8 requires that you be using
a) a terminal program that supports UTF-8 (gnome-terminal from Red Hat Linux 8.0
or later including Taroon is what I use and can say works; with others, your
mileage may vary)
b) a terminal emulator that either supports UTF-8 or is just extremely dumb at
passing things through.  minicom is not sufficient.  Hyperterminal almost
certainly doesn't work.  kermit does work, at least under Linux.

If you don't have this, then you shouldn't add 'utf8' on your command line and
will fallback to lowest common denominator vt100 (which is black and white by
the spec) and this is why we don't do utf8 mode by default.

Note You need to log in before you can comment on or make changes to this bug.