Bug 1032098 - packstack generated answer file is different than all-in-one answerfile
packstack generated answer file is different than all-in-one answerfile
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 09:43 EST by Mohammed Arafa
Modified: 2013-11-26 12:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 12:57:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2013-11-19 09:43:39 EST
Description of problem:
if you run packstack --allinone, a packstack answer file is generated and saved in /root.

however, if you run packstack --gen-answer-file=GEN_ANSWER_FILE, that answer file is _different_ than the one run.

the assumption here is that by generating the file we can identify what configuration is being used by packstack --allinone.

unfortunately, this is not true

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Mohammed Arafa 2013-11-20 15:18:06 EST
adding the differences for easy eyeballing:

[root@openstack02 ~(keystone_admin)]#arch)`dif': diff packstack-answers-20131120-042257.txt packstack.answer.orig| grep -vE "PW|TOKEN|SECRET"
34c34
< CONFIG_SWIFT_INSTALL=y
---
> CONFIG_SWIFT_INSTALL=n
53c53
< CONFIG_NAGIOS_INSTALL=y
---
> CONFIG_NAGIOS_INSTALL=n
68c68
---
77c77
---
80c80
---
83c83
---
86c86
---
95c95
---
98c98
---
104c104
---
107c107
---
149c149
---
152c152
---
167c167
< CONFIG_NOVA_COMPUTE_PRIVIF=lo
---
> CONFIG_NOVA_COMPUTE_PRIVIF=eth1
180c180
< CONFIG_NOVA_NETWORK_PRIVIF=lo
---
> CONFIG_NOVA_NETWORK_PRIVIF=eth1
209c209
---
212c212
---
235c235
---
294c294
---
316c316
< CONFIG_PROVISION_DEMO=y
---
> CONFIG_PROVISION_DEMO=n
332c332
< CONFIG_PROVISION_ALL_IN_ONE_OVS_BRIDGE=y
---
> CONFIG_PROVISION_ALL_IN_ONE_OVS_BRIDGE=n
338c338
---
341c341
---
363c363
---
366c366
---
379c379
---
Comment 3 Alvaro Lopez Ortega 2013-11-26 12:57:24 EST
The "all in one" option is there for a reason. When used, it's expected to get a different answer file. 

--gen-answer-file and --allinone are complementary options, and so the described behaviour is intended.

Note You need to log in before you can comment on or make changes to this bug.