Bug 1032157 - Cannot import from Flat File Source on MacOS
Cannot import from Flat File Source on MacOS
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 10:57 EST by Lucie Fabrikova
Modified: 2014-07-09 01:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Some users are receiving a "No difference report was found" error on MacOS when using the DDL Importer to import from a flat file source.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 10:32:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-1885 Major Closed DDL importer problems - TeiidServerManager initialization problem 2014-01-03 10:15:25 EST

  None (edit)
Description Lucie Fabrikova 2013-11-19 10:57:56 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 JBoss JIRA Server 2013-11-20 08:29:45 EST
Paul Richardson <p.g.richardson@phantomjinx.co.uk> made a comment on jira TEIIDDES-1885

Debugging this on linux (so not quite the right platform) ...

Placing a breakpoint on TeiidServerManager's constructor demonstrates that an instance is being correctly instantiated once ModelerCore.getTeiidServerManager() is called. Likewise, a subsequent breakpoint on TeiidServerManager.getTeiidServerVersion() indicates a successful return of a version number.

[~lfabriko] are you able to apply similar breakpoints and test whether this is the case on macOs?
Comment 3 JBoss JIRA Server 2013-11-21 07:14:00 EST
Lucie Fabrikova <lfabriko@redhat.com> made a comment on jira TEIIDDES-1885

I debugged Teiid Designer on MacOS, applied given breakpoints - and the model was imported correctly. The error message didn't occur at all; and TeiidServerManager wasn't null.
Comment 4 JBoss JIRA Server 2013-11-21 09:47:28 EST
Lucie Fabrikova <lfabriko@redhat.com> made a comment on jira TEIIDDES-1885

The problem seems to be an issue with the automatized test environment setup, I couldn't reproduce it manually as a user. 

Workaround for the automatized test: switch to tab "Servers" and invoke the "New server definition" wizard. Next, the DDL can be imported...
Comment 5 JBoss JIRA Server 2013-11-21 10:15:04 EST
Lucie Fabrikova <lfabriko@redhat.com> updated the status of jira TEIIDDES-1885 to Closed

Note You need to log in before you can comment on or make changes to this bug.