Bug 1032169 - prompt reads -bash-4.1
prompt reads -bash-4.1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: guest-images (Show other bugs)
6.5
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
node
: ZStream
Depends On:
Blocks: 1045487
  Show dependency treegraph
 
Reported: 2013-11-19 11:23 EST by Jaroslav Henner
Modified: 2016-04-26 09:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-22 14:43:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2013-11-19 11:23:01 EST
Description of problem:
The prompt, after ssh login to root looks like:
-bash-4.1#

it seems \s in the $PS1 evaluated to -bash because the zeroth argument to it is, for some reason, -bash. It may be good to include the hostname, not the bash version to the prompt anyway.

Version-Release number of selected component (if applicable):
rhel-guest-image-6-6.5-20131115.0

How reproducible:
always

Steps to Reproduce:
1. nova boot with following cloud-config and root ssh key injecting.
#cloud-config
disable_root: false
2. add floating ip, ssh to the instance
3. observe the prompt

Actual results:
-bash-4.1# 


Expected results:
hostname in the prompt

Additional info:
-bash-4.1# echo $PS1
\s-\v\$
-bash-4.1# ps aux | grep bash
root      2317  0.0  0.0 108304  1956 pts/0    Ss   15:58   0:00 -bash
root      2632  0.0  0.0 103244   880 pts/0    S+   16:12   0:00 grep bash
Comment 2 RHEL Product and Program Management 2013-11-22 12:24:35 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 yuliu 2014-09-11 02:08:36 EDT
Version
rhel-guest-image-6.6-20140910.0.x86_64.qcow2

Steps:

1. ssh connect to booted image
2. check the PS1 
[root@localhost ~]# echo $PS1
[\u@\h \W]\$


Verified as above.
Comment 9 errata-xmlrpc 2014-10-22 14:43:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1697.html

Note You need to log in before you can comment on or make changes to this bug.