Bug 1032178 - Puppet repositories are not exposed via HTTP even with 'unprotected' flag set.
Puppet repositories are not exposed via HTTP even with 'unprotected' flag set.
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: 6.2
Assigned To: Brad Buckingham
Og Maciel
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 11:38 EST by Justin Sherrill
Modified: 2016-07-27 07:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:41:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13182 None None None 2016-04-22 12:14 EDT

  None (edit)
Description Justin Sherrill 2013-11-19 11:38:42 EST
Description of problem:

As part of 1aa2292c20cf11bb2fcdf8a9006eb43719bd40c7 we switched from the PuppetDistributor to the PuppetInstallDistributor.  This enabled us to deploy modules to a puppet master but makes it so they are not exposed over http.

We should add the PuppetDistributor back so that they are exposed.

Version-Release number of selected component (if applicable):
6.0.2

How reproducible:
Always

Steps to Reproduce:
1.  Create a new puppet repository and check 'unprotected'
2.  Either sync content from puppetforge or push content to it via katello cli
3.  Visit the repository details page and look for the repo url
4.  Click the repo url

Actual results:
404

Expected results:
Puppet repository is displayed/
Comment 2 Brad Buckingham 2016-01-13 12:05:18 EST
Created redmine issue http://projects.theforeman.org/issues/13182 from this bug
Comment 3 Bryan Kearney 2016-01-25 18:02:37 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13182 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|e2f9a7f5b5fa5de74ceb28342d2823105b9ec859.
Comment 5 Og Maciel 2016-03-24 11:13:52 EDT
Verified that this works as expected by:

* Created a custom puppet-based repo pointed at a small-ish puppet repository, choosing the option to publish it via http
* Synchronized it
* Used the web ui and curl to visit the published repo:

~ » curl http://<SERVER>/pulp/puppet/Default_Organization-Puppet-RandomModule/
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<html>
 <head>
  <title>Index of /pulp/puppet/Default_Organization-Puppet-RandomModule</title>
 </head>
 <body>
<h1>Index of /pulp/puppet/Default_Organization-Puppet-RandomModule</h1>
  <table>
   <tr><th valign="top"><img src="/icons/blank.gif" alt="[ICO]"></th><th><a href="?C=N;O=D">Name</a></th><th><a href="?C=M;O=A">Last modified</a></th><th><a href="?C=S;O=A">Size</a></th><th><a href="?C=D;O=A">Description</a></th></tr>
   <tr><th colspan="5"><hr></th></tr>
<tr><td valign="top"><img src="/icons/back.gif" alt="[PARENTDIR]"></td><td><a href="/pulp/puppet/">Parent Directory</a></td><td>&nbsp;</td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top"><img src="/icons/unknown.gif" alt="[   ]"></td><td><a href="modules.json">modules.json</a></td><td align="right">2016-03-24 11:06  </td><td align="right"> 78 </td><td>&nbsp;</td></tr>
<tr><td valign="top"><img src="/icons/folder.gif" alt="[DIR]"></td><td><a href="system/">system/</a></td><td align="right">2016-03-24 11:06  </td><td align="right">  - </td><td>&nbsp;</td></tr>
   <tr><th colspan="5"><hr></th></tr>
</table>
</body></html>


~ » curl http://<SERVER>/pulp/puppet/Default_Organization-Puppet-RandomModule/system/
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<html>
 <head>
  <title>Index of /pulp/puppet/Default_Organization-Puppet-RandomModule/system</title>
 </head>
 <body>
<h1>Index of /pulp/puppet/Default_Organization-Puppet-RandomModule/system</h1>
  <table>
   <tr><th valign="top"><img src="/icons/blank.gif" alt="[ICO]"></th><th><a href="?C=N;O=D">Name</a></th><th><a href="?C=M;O=A">Last modified</a></th><th><a href="?C=S;O=A">Size</a></th><th><a href="?C=D;O=A">Description</a></th></tr>
   <tr><th colspan="5"><hr></th></tr>
<tr><td valign="top"><img src="/icons/back.gif" alt="[PARENTDIR]"></td><td><a href="/pulp/puppet/Default_Organization-Puppet-RandomModule/">Parent Directory</a></td><td>&nbsp;</td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top"><img src="/icons/folder.gif" alt="[DIR]"></td><td><a href="releases/">releases/</a></td><td align="right">2016-03-24 11:06  </td><td align="right">  - </td><td>&nbsp;</td></tr>
   <tr><th colspan="5"><hr></th></tr>
</table>
</body></html>
~ »
Comment 6 Bryan Kearney 2016-07-27 07:41:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.