Bug 1032199 - RHQ may overwrite storage node (Cassandra) replication settings
RHQ may overwrite storage node (Cassandra) replication settings
Status: CLOSED DUPLICATE of bug 1015835
Product: RHQ Project
Classification: Other
Component: Storage Node (Show other bugs)
4.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 12:25 EST by Elias Ross
Modified: 2014-05-06 21:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-06 21:06:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elias Ross 2013-11-19 12:25:12 EST
Description of problem:

RHQ automatically updates the replication factor when new storage nodes are added or nodes are removed. In some instances, the replication may be set to NetworkTopologyStrategy and RHQ can alter this (back) to SimpleStrategy.

(Of course, this can't be done through RHQ itself, this is done for setting up multi-datacenter replication.)


Version-Release number of selected component (if applicable): 4.9


How reproducible: If number of nodes is less than 4


Steps to Reproduce:
1. Set strategy to NetworkTopologyStrategy for keyspace 'rhq'
2. Add an additional node


Actual results:
Note the strategy was updated

Expected results:
No change

Additional info:
Comment 1 Elias Ross 2014-05-06 21:06:54 EDT
This seem

*** This bug has been marked as a duplicate of bug 1015835 ***

Note You need to log in before you can comment on or make changes to this bug.