Bug 1032208 - virtio-scsi controller causes migration to fail
virtio-scsi controller causes migration to fail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: seabios (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 12:37 EST by Martin Betak
Modified: 2014-03-24 02:39 EDT (History)
11 users (show)

See Also:
Fixed In Version: seabios-1.7.2.2-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-24 02:39:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failing vm (1.78 KB, text/xml)
2013-11-19 12:43 EST, Martin Betak
no flags Details
working vm (1.79 KB, text/xml)
2013-11-19 12:44 EST, Martin Betak
no flags Details
destination qemu vm.log (89.65 KB, text/x-log)
2013-11-19 12:46 EST, Martin Betak
no flags Details
source qemu vm.log (57.65 KB, text/x-log)
2013-11-19 12:47 EST, Martin Betak
no flags Details
source libvirt log (5.70 MB, text/x-log)
2013-11-19 12:51 EST, Martin Betak
no flags Details
destination libvirt log (5.82 MB, text/x-log)
2013-11-19 12:53 EST, Martin Betak
no flags Details

  None (edit)
Description Martin Betak 2013-11-19 12:37:15 EST
Description of problem:
Migration fails on VMs with <controller type="scsi" device present.


Version-Release number of selected component (if applicable):
same setup on both source (dev-11) and destination (dev-15)

qemu-1.4.2-14.fc19.x86_64
libvirt-1.0.5.7-2.fc19.x86_64
kernel-3.11.8-200.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. virsh create vm-min-scsi.xml (see attachment)
2. virsh migrate vm qemu+ssh://dev-15/system
3. check qemu logs for VM 'vm'

Actual results:
Vm is killed during migration after 
qemu-system-x86_64: virtio: trying to map MMIO memory

Expected results:
Vm should be up and running on destination after migration


Additional info:
Migration fails only when the scsi controller is present in the domain xml.
Also tested migration with vm-min.xml (attached, scsi controller removed) and that works - last entry in dst_qemu.log @ 17:05
Comment 1 Martin Betak 2013-11-19 12:43:48 EST
Created attachment 826217 [details]
failing vm
Comment 2 Martin Betak 2013-11-19 12:44:36 EST
Created attachment 826218 [details]
working vm
Comment 3 Martin Betak 2013-11-19 12:46:22 EST
Created attachment 826219 [details]
destination qemu vm.log
Comment 4 Martin Betak 2013-11-19 12:47:11 EST
Created attachment 826220 [details]
source qemu vm.log
Comment 5 Martin Betak 2013-11-19 12:51:58 EST
Created attachment 826221 [details]
source libvirt log
Comment 6 Martin Betak 2013-11-19 12:53:48 EST
Created attachment 826222 [details]
destination libvirt log
Comment 7 Cole Robinson 2014-03-13 14:32:41 EDT
Looks like this is:

https://bugzilla.redhat.com/show_bug.cgi?id=1013418

Which is fixed with a seabios patch:

http://git.qemu.org/?p=seabios.git;a=commit;h=5f2d17d35b2339526f3b3d580b279ea78e406a25

Needed in f19, f20, and rawhide
Comment 8 Fedora Update System 2014-03-13 17:13:00 EDT
seabios-1.7.2.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/seabios-1.7.2.2-3.fc19
Comment 9 Fedora Update System 2014-03-15 11:06:26 EDT
Package seabios-1.7.2.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing seabios-1.7.2.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3852/seabios-1.7.2.2-3.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-03-24 02:39:50 EDT
seabios-1.7.2.2-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.