Bug 1032228 - TUI installations fails to pass keyboard page
TUI installations fails to pass keyboard page
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.3
All Linux
urgent Severity urgent
: ---
: 3.4.1
Assigned To: Fabian Deutsch
bugs@ovirt.org
node
:
Depends On:
Blocks: 1033287
  Show dependency treegraph
 
Reported: 2013-11-19 13:24 EST by Douglas Schilling Landgraf
Modified: 2014-03-26 19:53 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 19:53:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I retreived /var/logs before wiping the disk, here you go (566.60 KB, application/x-gzip)
2013-12-02 09:51 EST, Netbulae
no flags Details
/var/log directory (405.21 KB, application/gzip)
2013-12-03 04:58 EST, Jonas Israelsson
no flags Details
New set of logfiles now with /tmp/ovirt.log included (459.97 KB, application/gzip)
2013-12-03 13:41 EST, Jonas Israelsson
no flags Details

  None (edit)
Description Douglas Schilling Landgraf 2013-11-19 13:24:39 EST
Description of problem:

After keyboard layout selected on TUI the installer drops to console with:

Press ENTER to logout...
or enter 's' to drop to shell

/var/log/ovirt.log
Traceback (most recent call last):
  File "<stdin>", line 2, in <module>
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/firewall.py", line 123, in process_plugins 
File "/usr/lib/python2.7/site-packages/ovirt/node/utils/firewall.py", line 78, in setup_iptables
File "/usr/lib/python2.7/site-packages/ovirt/node/utils/firewall.py", line 57, in is_open 
File "/usr/lib/python2.7/site-packages/ovirt/node/utils/firewall.py", line 77, in check_output
TypeError: unicode() argument 2 must be string, not None
  

ISO:
http://fedorapeople.org/~fabiand/node/3.0.2/ovirt-node-iso-3.0.2-1.0.0.vdsm.fc19.iso
Comment 1 Fabian Deutsch 2013-11-20 06:33:02 EST
This seems to be some kind of race.

It is not 100% reproducable.
Comment 2 Sven Kieske 2013-11-21 07:56:00 EST
Hi, I tried to reproduce this on real hardware, with this iso:
http://fedorapeople.org/~fabiand/node/3.0.2/ovirt-node-iso-3.0.2-1.0.0.vdsm.fc19.iso

mounted via IPMI, selected keyboard de_nodeadkeys, installed flawless.

So I can't reproduce this, I think you might need more info from the system
where the installation failed, and try to reproduce it with exactly the same
setup.

HTH
Comment 3 Douglas Schilling Landgraf 2013-11-21 09:56:47 EST
(In reply to Sven Kieske from comment #2)
> Hi, I tried to reproduce this on real hardware, with this iso:
> http://fedorapeople.org/~fabiand/node/3.0.2/ovirt-node-iso-3.0.2-1.0.0.vdsm.
> fc19.iso
> 
> mounted via IPMI, selected keyboard de_nodeadkeys, installed flawless.
> 
> So I can't reproduce this, I think you might need more info from the system
> where the installation failed, and try to reproduce it with exactly the same
> setup.
> 
> HTH

Thanks Sven.

I am installing the ISO as virtual machine and executed the following steps:

On a fresh install
- In grub, select install, wait for installer come up
- hit enter to select install, (next screen *do not* press enter) hit tab, right, right, hit enter (to continue)

I have reproduced this a few times, with the above steps. However, looks like I am the only one at moment.
Comment 4 Sven Kieske 2013-11-21 10:10:34 EST
Maybe this just occurs with a special lbvirt/kvm combination(assuming you use those)?
Comment 5 Douglas Schilling Landgraf 2013-11-21 13:21:27 EST
(In reply to Sven Kieske from comment #4)
> Maybe this just occurs with a special lbvirt/kvm combination(assuming you
> use those)?

I could reproduce it using a real hardware. 

It goes to:
Press ENTER to logout...
or enter 's' to drop to shell

I cannot reproduce it using ovirt-node-installer --debug.
Comment 6 Fabian Deutsch 2013-11-21 14:50:00 EST
Douglas,

as you are currently the only one who can reproduce it, could you write out each keypress you do? :)
Comment 7 Douglas Schilling Landgraf 2013-11-21 16:47:15 EST
Hey Fabian,

(In reply to Fabian Deutsch from comment #6)
> Douglas,
> 
> as you are currently the only one who can reproduce it, could you write out
> each keypress you do? :)

On a fresh install (not often reproduced) 
- In grub, select install, wait for installer come up
- hit enter to select install, (next screen *do not* press enter) hit tab, right, right, hit enter (to continue)

Here a video:
http://people.redhat.com/dlandgra/bz1032228/node-failed-install.mpg
Comment 8 Netbulae 2013-12-02 08:10:44 EST
I had the same issue today trying to reinstall the node image from pxe. After failing to reinstall, I just wiped the disk and did an install that didn't give this error.

So definately more than one person having this issue ;-)
Comment 9 Fabian Deutsch 2013-12-02 08:44:24 EST
(In reply to Netbulae from comment #8)
> I had the same issue today trying to reinstall the node image from pxe.
> After failing to reinstall, I just wiped the disk and did an install that
> didn't give this error.
> 
> So definately more than one person having this issue ;-)

:)

Could you please help debugging the issue and follow these instructions

http://www.ovirt.org/Node_Troubleshooting#Debug_Mode

and attach the log files to this bug

https://bugzilla.redhat.com/show_bug.cgi?id=1032228
Comment 10 Netbulae 2013-12-02 09:51:22 EST
Created attachment 831620 [details]
I retreived /var/logs before wiping the disk, here you go
Comment 11 Jonas Israelsson 2013-12-03 04:56:04 EST
The problem description in the 'original post" in the mailing list [1] slightly differs to the one in this BZ, hence I am unsure if we are hunting two different problems. Please let me know if preferred to move this to a separate bug report.  

I am however experiencing exactly the same behaviour as in the original post.

<snip>

At the 'Keyboard layout selection' screen I press enter to select the default 'US English' option.
After a few seconds delay I then get this error screen:

An exception occurred
'other'
<close>

After pressing close I'm then back at the 'Keyboard layout selection' screen.
If I then press enter on 'US international' then tab down to the option to continue I can make my way to the screen where I have to enter the password for the admin user.  After continuing from there I immediately get an error on the install progress screen - at the 40% point.
The error reads:

Exception:
Value Error ('invalid literal for int() with base10: ''",)
<reboot>

</snip>   

Attached you find the whole /var/log directory from an install attempt with debug set.

ISO Used: ovirt-node-iso-3.0.3-1.1.vdsm.fc19.iso

[1] http://lists.ovirt.org/pipermail/users/2013-December/018323.html
Comment 12 Jonas Israelsson 2013-12-03 04:58:35 EST
Created attachment 831957 [details]
/var/log directory

Log files from a failed node install attempt with debug enabled.
Comment 13 Jonas Israelsson 2013-12-03 05:08:36 EST
Probably irrelevant but I instead choose Swedish as keyboard layout. Tried also to leave the keyboard layout as default but that made no difference.

Furthermore I have tired and failed to install the node on two different physical machines, both dell laptops.
Comment 14 Fabian Deutsch 2013-12-03 07:23:26 EST
Hey,

mh - it seems that the debug log is written to /tmp/ovirt-node.debug.log.

Could either of you please attach /tmp/ovirt-node.debug.log too?
Comment 15 Jonas Israelsson 2013-12-03 13:41:33 EST
Created attachment 832255 [details]
New set of logfiles now with /tmp/ovirt.log included
Comment 16 Fabian Deutsch 2013-12-11 03:44:26 EST
(In reply to Jonas Israelsson from comment #15)
> Created attachment 832255 [details]
> New set of logfiles now with /tmp/ovirt.log included

Thanks.

could you please post the output of

$ sfdisk -s -l <device you selected on the storage page>
Comment 17 Jonas Israelsson 2013-12-11 05:54:09 EST
125034840

Disk /dev/sda: 15566 cylinders, 255 heads, 63 sectors/track

This is a SSD Disk..
Comment 18 Jonas Israelsson 2014-01-27 04:31:05 EST
FYI, With the latest test-day release announced here http://lists.ovirt.org/pipermail/node-devel/2014-January/000589.html I have been able to install several machines that I previously could not due to this bug.
Comment 19 Fabian Deutsch 2014-01-27 07:29:57 EST
Thanks for that feedback Jonas!
Comment 20 Netbulae 2014-01-27 10:53:12 EST
I just tried this node iso and it works here too. Thanks!
Comment 21 Sandro Bonazzola 2014-03-04 04:23:41 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 22 Doron Fediuck 2014-03-12 22:04:25 EDT
Based on comment 20 and comment 18, can we close the bug?
Comment 23 Douglas Schilling Landgraf 2014-03-14 15:41:29 EDT
(In reply to Doron Fediuck from comment #22)
> Based on comment 20 and comment 18, can we close the bug?

Yes, worked for me too.
Comment 24 Doron Fediuck 2014-03-26 19:53:34 EDT
Closing per comment 23.

Note You need to log in before you can comment on or make changes to this bug.