Bug 103224 - local printer must be the default
local printer must be the default
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 17:37 EDT by Bob T.
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.6.83-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-18 07:40:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob T. 2003-08-27 17:37:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030813
Mozilla Firebird/0.6.1

Description of problem:
It seems I can't add a local printer that isn't the default printer.
There isn't even a way to undefault the automatically defaulted printer.
Why shouldn't I be allowed to specify a networked printer as the default printer
on a system?  Is this a CUPS limitation?

Version-Release number of selected component (if applicable):
0.6.47-1

How reproducible:
Always

Steps to Reproduce:
1. Add a local printer
2. Try to undefault it.
3.
    

Actual Results:  A local printer is automatically the default printer and this
can't be changed in any way that I can see.

Expected Results:  A sysadmin should be able to make a networked printer the
default. 

Additional info:
Comment 1 Tim Waugh 2003-08-28 05:59:51 EDT
Yes, this is a CUPS limitation.  There is no mechanism for either

a) setting a system's default printer to be a remote queue name, or
b) making a system's default printer override local defaults when browsed
Comment 2 John Franks 2003-09-10 10:36:52 EDT
Perhaps I did not completely understand the question, but I believe I have
successfully configured a remote (browsed) printer as default.  It took a lot of
experimentation and it may not work for you and may not continue to work for me. 

The easiest way is to run gnome-print-manager as root and select the desired
(remote browsed) printer and then under the "Printer" menu select "Set as
Default". This must be done as root and then affects all users on that computer.
 As near as I can tell what this does is alter the file /etc/cups/lpoptions and
adds a  line like 

     Default browsed_queue

where browsed_queue is the name of the cups browsed printer.  If you re-run
gnome-print-manager and set loc_printer as the default the effect on this file
will be to change 

     Default browsed_queue
     Dest loc_printer <whatever>

to 

    Default loc_printer <whatever>
Comment 3 Tim Waugh 2003-09-10 10:49:27 EDT
Aha.  That's worth knowing.  Thanks.
Comment 4 Bob T. 2003-09-10 10:55:57 EDT
  "I believe I have successfully configured a remote (browsed) printer as    
default."

But is there a *local* printer as well? My complaint was that I couldn't set a
networked printer as the default if there was *also* a local printer.
Comment 5 John Franks 2003-09-10 11:36:17 EDT
> But is there a *local* printer as well? My complaint was that I couldn't set a
> networked printer as the default if there was *also* a local printer.

Yes, this works when there are both local and browsed printers.  I have not
tested it extensively, but I just tried it and it worked fine.  You need to be
careful that no PRINTER environment variable is set since that will override
everything.
Comment 6 John Franks 2003-09-10 11:41:19 EDT
BTW if modifying /etc/cups/lpoptions and setting "Default" is indeed the correct
and intended way to notify cups of the default printer, then there is a bug in
lpadmin as "lpadmin -d print_queue" does NOT do this.
Comment 7 Tim Waugh 2003-11-18 07:40:54 EST
I think this should be fixed in 0.6.83-1 in the Fedora 'development' tree.
Comment 8 Aleksey Nogin 2006-05-09 20:01:41 EDT
I have not checked it in a recent distro, but in FC3, with both local and remote
printers:

1) system-config-printer is happy to let me mark a remote printer as a default
(and on subsequent invocations it remembers that I did it), but this does not
seem to have any effect

2) lpadmin -d foo does not have any effect either!

I had to edit /etc/cups/lpoptions manually.

Note You need to log in before you can comment on or make changes to this bug.