Bug 1032243 - *** Use "subscription-manager override" if you wish to make changes. ***
*** Use "subscription-manager override" if you wish to make changes. ***
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Stead
John Sefler
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-11-19 14:02 EST by John Sefler
Modified: 2014-06-17 20:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:22:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-11-19 14:02:46 EST
Description of problem:
Please update this warning string found in the redhat.repo to use the module "repo-override --help" and not "override".  There was a name change that was not fully propagated.


Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.10.7-1.git.0.15d737b.el7.x86_64


Steps to Reproduce:
1. register
2. yum clean all
3...
[root@jsefler-7 ~]# cat /etc/yum.repos.d/redhat.repo  | head -10
#
# Certificate-Based Repositories
# Managed by (rhsm) subscription-manager
#
# *** This file is auto-generated.  Changes made here will be over-written. ***
# *** Use "subscription-manager override" if you wish to make changes. ***
#
# If this file is empty and this system is subscribed consider 
# a "yum repolist" to refresh available repos
#


Actual results:
above

Expected results:
*** Use "subscription-manager repo-override --help" if you wish to make changes. ***


Additional info:
The reason I suggest "subscription-manager repo-override --help" is because it will display the syntax for the real options that are needed such as --repo=REPOID and --add=NAME:VALUE.  Calling "subscription-manager repo-override" will default to use the --list option and will not actually tell the user how to add repo overrides.
Comment 1 Michael Stead 2013-11-26 09:17:33 EST
Fixed in PR:
https://github.com/candlepin/subscription-manager/pull/827

Available in:
subscription-manager-1.10.8-1+
Comment 3 John Sefler 2013-12-06 11:57:38 EST
Verifying Version...
[root@jsefler-7 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription-manager: 1.10.8-1.el7
python-rhsm: 1.10.8-1.el7

[root@jsefler-7 ~]# subscription-manager register --username=rhel7beta --serverurl=subscription.rhn.stage.redhat.com:443/subscription --auto-attach
Password: 
The system has been registered with ID: 4739ecdf-4070-448a-941e-f582bbb7dffd 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux 7 Server High Touch Beta
Status:       Subscribed

[root@jsefler-7 ~]# head /etc/yum.repos.d/redhat.repo 
#
# Certificate-Based Repositories
# Managed by (rhsm) subscription-manager
#
# *** This file is auto-generated.  Changes made here will be over-written. ***
# *** Use "subscription-manager repo-override --help" if you wish to make changes. ***
#
# If this file is empty and this system is subscribed consider 
# a "yum repolist" to refresh available repos
#



VERIFIED: *** Use "subscription-manager repo-override --help" if you wish to make changes. ***
Comment 4 Ludek Smid 2014-06-13 06:22:13 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.