Bug 1032315 - attrcrypt fails to find unlocked key
attrcrypt fails to find unlocked key
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks: 1032316 1061410
  Show dependency treegraph
 
Reported: 2013-11-19 19:36 EST by Rich Megginson
Modified: 2014-10-14 03:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1032316 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2013-11-19 19:36:57 EST
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47596

When doing client cert based authentication for replication or chaining, and attrcrypt attempts to find the server's cert and key, it can get confused and attempt to use the wrong key.  Apparently in openldap's NSS implementation, the cert can end up on a token that has not been logged out, and the server will try to read the pin for the token/slot on stdin.
Comment 2 Sankar Ramalingam 2014-06-19 07:17:55 EDT
Request you to add steps to verify bugzilla.
Comment 3 Rich Megginson 2014-06-19 10:19:02 EDT
(In reply to Sankar Ramalingam from comment #2)
> Request you to add steps to verify bugzilla.

I found this bug running the mmrepl/accept tests.  To verify, make sure you do not see any attrcrypt error messages in the errors log for any of the suppliers/consumers during the mmrepl/accept tests.
Comment 4 Viktor Ashirov 2014-07-22 08:34:37 EDT
No attrcrypt errors were observed during mmrepl/accept tests run. Hence marking as verified.
Comment 5 errata-xmlrpc 2014-10-14 03:52:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.