Bug 1032348 - Add a view to edit server settings
Add a view to edit server settings
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.6
Assigned To: Lee Newson
:
Depends On: 1013888
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 21:36 EST by Lee Newson
Modified: 2014-05-28 17:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-28 17:56:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2013-11-19 21:36:43 EST
With the addition of server settings to hold entity ids and server specific settings, we should create a view in the UI to provide a way to see the values and edit them.
Comment 1 Lee Newson 2014-01-19 18:16:30 EST
Moving this back to NEW, as due to some other things coming up during the 1.4 sprint we won't have time to implement this RFE.
Comment 2 Lee Newson 2014-05-21 20:54:48 EDT
Added in 1.6-SNAPSHOT build 201405221035

There is now a "Server Settings" option under the advanced tab which will display the server settings and entities.

Some things to note:

- Entities are readonly, this is because it is a one time setting that won't ever change. (This part is also enforced by the server)

- The teiid and bugzilla urls aren't displayed as they aren't returned by the server. This is because they currently can't be updated at runtime, as such I've logged BZ#1100082 to deal with that.

- The SEO Category Ids and DocBook Template Ids don't allow you to pick from the current list. This is done for two reasons: these values (especially the seo one) would be better suited to columns on database tables and the other reason is as mentioned on IRC I missed them so I've done a quick implementation and plan to look at them in a later release.

Note: This version has been deployed to the test/development server.
Comment 3 Matthew Casperson 2014-05-22 16:28:47 EDT
Confirmed that all application settings can be edited, saved to the config files and reverted.

The value field in the custom entities section under the entities tab could not be edited in either chrome or firefox.
Comment 4 Matthew Casperson 2014-05-22 18:45:47 EDT
Ignore my last comment. That field only accepts numbers.

Note You need to log in before you can comment on or make changes to this bug.