Bug 1032421 - Attempt to install 1.2 nightly fails because of nodejs010-nodejs dependencies
Attempt to install 1.2 nightly fails because of nodejs010-nodejs dependencies
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 02:32 EST by Jan Pazdziora
Modified: 2017-03-08 12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 08:30:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2013-11-20 02:32:54 EST
Description of problem:

When attempting to run ./openshift.sh with latest 1.2 composes, the command

   yum install -y rubygem-openshift-origin-node ruby193-rubygem-passenger-native openshift-origin-port-proxy openshift-origin-node-util mcollective openshift-origin-msg-node-mcollective policycoreutils-python

fails.

Version-Release number of selected component (if applicable):

1.2/latest

How reproducible:

Seen once.

Steps to Reproduce:
1. Run ./openshift.sh with latest 1.2/latest repo.

Actual results:

+ echo 'OpenShift: yum install -y rubygem-openshift-origin-node ruby193-rubygem-passenger-native openshift-origin-port-proxy openshift-origin-node-util mcollective openshift-origin-msg-node-mcollective policycoreutils-python'
OpenShift: yum install -y rubygem-openshift-origin-node ruby193-rubygem-passenger-native openshift-origin-port-proxy openshift-origin-node-util mcollective openshift-origin-msg-node-mcollective policycoreutils-python
+ yum install -y -y rubygem-openshift-origin-node ruby193-rubygem-passenger-native openshift-origin-port-proxy openshift-origin-node-util mcollective openshift-origin-msg-node-mcollective policycoreutils-python
Loaded plugins: priorities, product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
3870 packages excluded due to repository priority protections
Setting up Install Process
Package ruby193-rubygem-passenger-native-3.0.21-3.el6op.x86_64 already installed and latest version
Package policycoreutils-python-2.0.83-19.39.el6.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package mcollective.noarch 0:2.2.1-6.el6op will be installed
---> Package openshift-origin-msg-node-mcollective.noarch 0:1.9.3-1.1.el6op will be installed
--> Processing Dependency: ruby193-facter for package: openshift-origin-msg-node-mcollective-1.9.3-1.1.el6op.noarch
---> Package openshift-origin-node-util.noarch 0:1.9.9.4-1.el6op will be installed
--> Processing Dependency: php >= 5.3.2 for package: openshift-origin-node-util-1.9.9.4-1.el6op.noarch
---> Package openshift-origin-port-proxy.noarch 0:1.6.4-1.el6op will be installed
--> Processing Dependency: haproxy for package: openshift-origin-port-proxy-1.6.4-1.el6op.noarch
---> Package rubygem-openshift-origin-node.noarch 0:1.9.14.6-1.el6op will be installed
--> Processing Dependency: unixODBC-devel for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Processing Dependency: unixODBC for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Processing Dependency: rubygem(open4) for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Processing Dependency: ruby193-rubygem(commander) for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Processing Dependency: ruby193-ruby(selinux) for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Processing Dependency: pam_openshift for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Processing Dependency: openshift-origin-node-proxy for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Processing Dependency: mercurial for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Processing Dependency: libcgroup-pam for package: rubygem-openshift-origin-node-1.9.14.6-1.el6op.noarch
--> Running transaction check
---> Package haproxy.x86_64 0:1.4.22-6.el6op will be installed
---> Package libcgroup-pam.x86_64 0:0.40.rc1-5.el6 will be installed
---> Package mercurial.x86_64 0:1.4-3.el6 will be installed
---> Package openshift-origin-node-proxy.noarch 0:0.9.5-1.el6op will be installed
--> Processing Dependency: nodejs010-nodejs-ws for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Processing Dependency: nodejs010-nodejs-supervisor for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Processing Dependency: nodejs010-nodejs-optimist for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Processing Dependency: nodejs010-nodejs-async for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Processing Dependency: nodejs010-nodejs for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
---> Package pam_openshift.x86_64 0:1.6.4-1.el6op will be installed
---> Package php.x86_64 0:5.3.3-26.el6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-26.el6 for package: php-5.3.3-26.el6.x86_64
--> Processing Dependency: php-cli(x86-64) = 5.3.3-26.el6 for package: php-5.3.3-26.el6.x86_64
---> Package ruby193-facter.x86_64 0:1.6.6-3.el6op will be installed
---> Package ruby193-ruby-selinux.x86_64 0:2.0.94-3.el6op will be installed
---> Package ruby193-rubygem-commander.noarch 0:4.0.3-5.el6op will be installed
--> Processing Dependency: ruby193-rubygem(highline) >= 1.5.0 for package: ruby193-rubygem-commander-4.0.3-5.el6op.noarch
---> Package rubygem-open4.noarch 0:1.3.0-2.el6op will be installed
--> Processing Dependency: rubygems for package: rubygem-open4-1.3.0-2.el6op.noarch
---> Package unixODBC.x86_64 0:2.2.14-12.el6_3 will be installed
--> Processing Dependency: libltdl.so.7()(64bit) for package: unixODBC-2.2.14-12.el6_3.x86_64
---> Package unixODBC-devel.x86_64 0:2.2.14-12.el6_3 will be installed
--> Running transaction check
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package nodejs010-nodejs-optimist.noarch 0:0.4.0-2.el6op will be installed
--> Processing Dependency: nodejs010-npm(wordwrap) < 0.1 for package: nodejs010-nodejs-optimist-0.4.0-2.el6op.noarch
--> Processing Dependency: nodejs010-npm(wordwrap) >= 0.0.2 for package: nodejs010-nodejs-optimist-0.4.0-2.el6op.noarch
--> Processing Dependency: nodejs010-nodejs(engine) for package: nodejs010-nodejs-optimist-0.4.0-2.el6op.noarch
---> Package nodejs010-nodejs-supervisor.noarch 0:0.5.2-3.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.3.7 for package: nodejs010-nodejs-supervisor-0.5.2-3.el6op.noarch
---> Package nodejs010-nodejs-ws.x86_64 0:0.4.25-6.el6op will be installed
--> Processing Dependency: nodejs010-npm(tinycolor) < 1 for package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64
--> Processing Dependency: nodejs010-npm(commander) >= 0.6.1 for package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64
--> Processing Dependency: nodejs010-npm(options) for package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64
---> Package openshift-origin-node-proxy.noarch 0:0.9.5-1.el6op will be installed
--> Processing Dependency: nodejs010-nodejs-async for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Processing Dependency: nodejs010-nodejs for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
---> Package php-cli.x86_64 0:5.3.3-26.el6 will be installed
---> Package php-common.x86_64 0:5.3.3-26.el6 will be installed
---> Package ruby193-rubygem-highline.noarch 0:1.6.16-1.el6op will be installed
---> Package rubygems.noarch 0:1.8.24-4.el6op will be installed
--> Running transaction check
---> Package nodejs010-nodejs-commander.noarch 0:1.1.1-3.el6op will be installed
--> Processing Dependency: nodejs010-npm(keypress) >= 0.1 for package: nodejs010-nodejs-commander-1.1.1-3.el6op.noarch
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.6.0 for package: nodejs010-nodejs-commander-1.1.1-3.el6op.noarch
---> Package nodejs010-nodejs-optimist.noarch 0:0.4.0-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) for package: nodejs010-nodejs-optimist-0.4.0-2.el6op.noarch
---> Package nodejs010-nodejs-options.noarch 0:0.0.5-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-options-0.0.5-2.el6op.noarch
---> Package nodejs010-nodejs-supervisor.noarch 0:0.5.2-3.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.3.7 for package: nodejs010-nodejs-supervisor-0.5.2-3.el6op.noarch
---> Package nodejs010-nodejs-tinycolor.noarch 0:0.0.1-5.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-tinycolor-0.0.1-5.el6op.noarch
---> Package nodejs010-nodejs-wordwrap.noarch 0:0.0.2-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-wordwrap-0.0.2-2.el6op.noarch
---> Package nodejs010-nodejs-ws.x86_64 0:0.4.25-6.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64
---> Package openshift-origin-node-proxy.noarch 0:0.9.5-1.el6op will be installed
--> Processing Dependency: nodejs010-nodejs-async for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Processing Dependency: nodejs010-nodejs for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Running transaction check
---> Package nodejs010-nodejs-commander.noarch 0:1.1.1-3.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.6.0 for package: nodejs010-nodejs-commander-1.1.1-3.el6op.noarch
---> Package nodejs010-nodejs-keypress.noarch 0:0.2.1-1.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) for package: nodejs010-nodejs-keypress-0.2.1-1.el6op.noarch
---> Package nodejs010-nodejs-optimist.noarch 0:0.4.0-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) for package: nodejs010-nodejs-optimist-0.4.0-2.el6op.noarch
---> Package nodejs010-nodejs-options.noarch 0:0.0.5-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-options-0.0.5-2.el6op.noarch
---> Package nodejs010-nodejs-supervisor.noarch 0:0.5.2-3.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.3.7 for package: nodejs010-nodejs-supervisor-0.5.2-3.el6op.noarch
---> Package nodejs010-nodejs-tinycolor.noarch 0:0.0.1-5.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-tinycolor-0.0.1-5.el6op.noarch
---> Package nodejs010-nodejs-wordwrap.noarch 0:0.0.2-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-wordwrap-0.0.2-2.el6op.noarch
---> Package nodejs010-nodejs-ws.x86_64 0:0.4.25-6.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64
---> Package openshift-origin-node-proxy.noarch 0:0.9.5-1.el6op will be installed
--> Processing Dependency: nodejs010-nodejs-async for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Processing Dependency: nodejs010-nodejs for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Finished Dependency Resolution
Error: Package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs
Error: Package: nodejs010-nodejs-options-0.0.5-2.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.4.0
Error: Package: nodejs010-nodejs-optimist-0.4.0-2.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine)
Error: Package: nodejs010-nodejs-tinycolor-0.0.1-5.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.4.0
Error: Package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64 (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.4.0
Error: Package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs-async
Error: Package: nodejs010-nodejs-supervisor-0.5.2-3.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.3.7
Error: Package: nodejs010-nodejs-wordwrap-0.0.2-2.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.4.0
Error: Package: nodejs010-nodejs-commander-1.1.1-3.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.6.0
Error: Package: nodejs010-nodejs-keypress-0.2.1-1.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
+ '[' 1 -ne 0 ']'
+ echo 'OpenShift: Command failed: yum install -y rubygem-openshift-origin-node ruby193-rubygem-passenger-native openshift-origin-port-proxy openshift-origin-node-util mcollective openshift-origin-msg-node-mcollective policycoreutils-python'

Expected results:

No error.

Additional info:
Comment 4 Miciah Dashiel Butler Masters 2014-01-15 16:55:56 EST
OSE 1.2 now requires software collections for Ruby and NodeJS packages, and it looks like you are missing some required packages that are shipped only in software collections.  Please run `yum repolist` and check the output.  Does it show that you have the rhel-server-rhscl-6-rpms repository enabled?

The versions of openshift.sh in Github in both the enterprise-1.2 and the enterprise-2.0 branched should enable the rhscl repository for you.  Are you using an old version of openshift.sh, or do the current scripts fail to enable the repository?

To fix the problem manually, first you need to enable the rhscl repo.  For example, if you are using RHSM, use the following command:

    # subscription-manager repos --enable=rhel-server-rhscl-6-rpms

Next, it would be a good idea to check that the repository is configured correctly.  We now ship a tool in OSE 1.2 and OSE 2.0 to verify both that the correct repositories are enabled and that they are configured correctly with the necessary priorities and exclusions.  To use this tool, use the following commands:

    # yum install openshift-enterprise-yum-validator
    # oo-admin-yum-validator

and follow the instructions in the output.  The tool will attempt to detect the installation method you used (RHN, RHSM, or Yum repositories), diagnose the current configuration, and output any potential errors and the commands to correct those errors.

Does the above resolve the issue?

Note You need to log in before you can comment on or make changes to this bug.