Bug 1032462 - Cannot create Filter rule for Mailing List
Cannot create Filter rule for Mailing List
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 04:22 EST by Mikhail
Modified: 2013-11-26 14:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 14:14:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Receiving Options (59.35 KB, image/png)
2013-11-21 06:52 EST, Mikhail
no flags Details
example message (4.84 KB, application/mbox)
2013-11-21 08:57 EST, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 719376 None None None Never

  None (edit)
Description Mikhail 2013-11-20 04:22:33 EST
Description of problem:
I am already create rule for mailing list "freetds@lists.ibiblio.org" which must automatacaly moving messages from inbox folder to FreeTDS folder. But I don't see that this rule works.

Demonstration how I create rule: https://drive.google.com/file/d/0B0nwzlfiB4aQNkdvN3hSTTlWNFE/edit?usp=sharing


Please help me.
Comment 1 Milan Crha 2013-11-20 04:40:11 EST
Thanks for a bug report. The filters are automatically applied only to newly received messages, not to those already in your Inbox. You can apply filters manually, by invoking Message->Apply Filters (Ctrl+Y), which tries to apply your filters to currently selected messages. I guess that's the step you are missing (or the one not shown in your video). In case the filter will not apply, it can be due to missing headers in the message, thus the condition may fail.
Comment 2 Mikhail 2013-11-20 05:14:21 EST
> The filters are automatically applied only to newly received messages

In my case newly received messages still appears in Inbox folder :(
Comment 3 Mikhail 2013-11-20 15:52:26 EST
Demonstration applying filter: https://drive.google.com/file/d/0B0nwzlfiB4aQTVNsc0VURHhTbjQ/edit?usp=sharing

but all new messages not automatically moved to "FreeTDS" folder :(
Comment 4 Milan Crha 2013-11-21 06:20:43 EST
Just in case, could you verify that Edit->Preferences->Mail Accounts-><ews account>->Receiving Options tab->Options section has set
  [x] Apply filters to new messages in Inbox on this server
please?
Comment 5 Mikhail 2013-11-21 06:52:52 EST
Created attachment 827154 [details]
Receiving Options
Comment 6 Mikhail 2013-11-21 08:57:00 EST
Created attachment 827208 [details]
example message
Comment 7 Milan Crha 2013-11-26 14:14:46 EST
Thanks for the update. I tested it locally and I can reproduce the issue with your message too. The reason is that the Message list header is not exposed by standard properties, or better it's not used by evolution-ews, thus in time of the message arrival the filtering subsystem doesn't know what mailing the message is from, if any. Let's move with this upstream, as this is not Fedora specific. The corresponding upstream bug report is [1].

[1] https://bugzilla.gnome.org/show_bug.cgi?id=719376
Comment 8 Milan Crha 2013-11-26 14:16:27 EST
By the way, temporary workaround would be to use "Subject contains [freetds]" instead of comparing the Mailing list directly.

Note You need to log in before you can comment on or make changes to this bug.