Bug 1032511 - abrt-harvest-vmcore crashes due to Permission denied error while accessing a VMCore directory
abrt-harvest-vmcore crashes due to Permission denied error while accessing a ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Filak
Martin Kyral
abrt_hash:ad7537cc884870f274c486993d1...
:
: 1060019 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 05:33 EST by Michal Domonkos
Modified: 2016-11-30 19:45 EST (History)
4 users (show)

See Also:
Fixed In Version: abrt-2.1.11-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.37 KB, text/plain)
2013-11-20 05:33 EST, Michal Domonkos
no flags Details
File: environ (72 bytes, text/plain)
2013-11-20 05:34 EST, Michal Domonkos
no flags Details

  None (edit)
Description Michal Domonkos 2013-11-20 05:33:51 EST
Version-Release number of selected component:
abrt-addon-vmcore-2.1.7-3.3.internal.el7

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python /usr/sbin/abrt-harvest-vmcore
executable:     /usr/sbin/abrt-harvest-vmcore
kernel:         3.10.0-52.el7.x86_64
runlevel:       unknown
type:           Python
uid:            0

Truncated backtrace:
abrt-harvest-vmcore:236:harvest_vmcore:OSError: [Errno 13] Permission denied: '/var/crash/127.0.0.1-2013.11.19-16:53:00'

Traceback (most recent call last):
  File "/usr/sbin/abrt-harvest-vmcore", line 283, in <module>
    harvest_vmcore()
  File "/usr/sbin/abrt-harvest-vmcore", line 236, in harvest_vmcore
    files = [ff for ff in os.listdir(f_full)
OSError: [Errno 13] Permission denied: '/var/crash/127.0.0.1-2013.11.19-16:53:00'

Local variables in innermost frame:
f_full: '/var/crash/127.0.0.1-2013.11.19-16:53:00'
cfile: '127.0.0.1-2013.11.19-16:53:00'
i: 0
filelist: ['127.0.0.1-2013.11.19-16:53:00']
conf_file: <closed file '/etc/abrt/abrt.conf', mode 'r' at 0xbba540>
conf_fp: <StringIO.StringIO instance at 0xc19d88>
dump_dir: '/var/crash'
abrtdumpdir: '/var/tmp/abrt'
copyvmcore: 'yes'
config: <ConfigParser.ConfigParser instance at 0xc19dd0>
conf_str: "[section]\n# Enable this if you want abrtd to auto-unpack crashdump tarballs which appear\n# in this directory (for example, uploaded via ftp, scp etc).\n# Note: you must ensure that whatever directory you specify here exists\n# and is writable for abrtd. abrtd will not create it automatically.\n#\n#WatchCrashdumpArchiveDir = /var/spool/abrt-upload\n\n# Max size for crash storage [MiB] or 0 for unlimited\n#\nMaxCrashReportsSize = 1000\n\n# Specify where you want to store coredumps and all files which are needed for\n# reporting. (default:/var/tmp/abrt)\n#\n# Changing dump location could cause problems with SELinux. See man abrt_selinux(8).\n#\n#DumpLocation = /var/tmp/abrt\n\n# If you want to automatically clean the upload directory you have to tweak the\n# selinux policy.\n#\nDeleteUploaded = no\n\n# A name of event which is run automatically after problem's detection. The\n# event should perform some fast analysis and exit with 70 if the\n# problem is known.\n#\n# In order to run this event automatically after detection, the\n# AutoreportingEnabled option must be configured to 'yes'\n#\n# Default value: report_uReport\n#\nAutoreportingEvent = report_uReport\n\n# Enables automatic running of the event configured in AutoreportingEvent option.\n#\nAutoreportingEnabled = no\n\n# Enables shortened GUI reporting where the reporting is interrupted after\n# AutoreportingEvent is done.\n#\n# Default value: Yes but only if application is running in GNOME desktop\n#                session; otherwise No.\n#\n# ShortenedReporting = yes\n"
Comment 1 Michal Domonkos 2013-11-20 05:33:56 EST
Created attachment 826546 [details]
File: backtrace
Comment 2 Michal Domonkos 2013-11-20 05:34:02 EST
Created attachment 826547 [details]
File: environ
Comment 4 Jakub Filak 2014-01-27 04:44:13 EST
Patches submitted for review:

https://github.com/abrt/abrt/pull/798
Comment 5 Jakub Filak 2014-01-31 04:37:51 EST
*** Bug 1060019 has been marked as a duplicate of this bug. ***
Comment 8 Ludek Smid 2014-06-13 07:14:22 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.