Bug 1032556 - few links are not working in "Mashup portlet on dashboard"
few links are not working in "Mashup portlet on dashboard"
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
low Severity medium
: ER05
: JON 3.3.0
Assigned To: Libor Zoubek
Mike Foley
Jared MORGAN
: Documentation
Depends On: 880359
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 06:50 EST by Jeeva Kandasamy
Modified: 2015-11-01 19:43 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:01:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1144468 None None None Never

  None (edit)
Description Jeeva Kandasamy 2013-11-20 06:50:05 EST
Description of problem:
Few links are not working on Mashup portlet on dashboard

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.2.0.ER6
Build Number : f7dcd50:643508a
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox 17.0.7 ESR (RHEL 6.4 x64)

How reproducible:
1/1

Steps to Reproduce:
1. Navigate to dashboard (Mashup portlet)
2. On Mashup click on the link "Downloads"
3. Bottom of the page on the section "System Management", click the following links, it displays blank.
- [Red Hat CloudForms], https://rhn.redhat.com/rhn/software/channel/downloads/Download.do?cid=20037
- [Red Hat JBoss Operations Network], https://access.redhat.com/jbossnetwork/restricted/listSoftware.html
- [Red Hat Network Satellite], https://rhn.redhat.com/rhn/software/channels/All.do


Actual results:
displays blank

Expected results:
Should display actual page
Comment 1 Jirka Kremser 2013-11-27 12:04:33 EST
this is caused by the fact that those URLs:
* https://rhn.redhat.com/rhn/software/channel/downloads/Download.do?cid=20037
* https://access.redhat.com/jbossnetwork/restricted/listSoftware.html
* https://rhn.redhat.com/rhn/software/channels/All.do

are actually redirects to some other page where the AuthN happens if not signed in

curl -I https://rhn.redhat.com/rhn/software/channel/downloads/Download.do?cid=20037

returns:
...
HTTP/1.1 302 Moved Temporarily
...
Location: https://www.redhat.com/wapps/sso/login.html?redirect=https%3A%2F%2Frhn.redhat.com%2Frhn%2Fsoftware%2Fchannel%2Fdownloads%2FDownload.do%3Fcid=20037

we use the HTMLPane SmartGWT component for the Mashup portlet. At the end of the day it is translated into the common iframe element. Unfortunately there is no way to make the iframe behave correctly (to follow the 302 redirects)
Comment 3 Jirka Kremser 2014-08-11 09:25:15 EDT
This bug is trivially fixed because of the fact the Mashup portlet was removed from JON. See bug 1123977 for more details.

As a consequence, there are no commits for this bug and therefore no need to cherry-picking.
Comment 4 Simeon Pinder 2014-08-19 19:50:31 EDT
Moving to ON_QA as available to test in the following brew build:

https://brewweb.devel.redhat.com//buildinfo?buildID=379025
Comment 5 Jirka Kremser 2014-08-21 03:37:40 EDT
In comment 3 I wrote: "Mashup portlet was removed". This is not true. Only the content of the Mashup portlet was replaced with own html page including some links:
* Product Landing Page
* Product Documentation
* Release Notes

And some of the new features in latest version - not yet implemented.

Links open new a browser tab. Therefore no need for AuthN inside iframed page.
Comment 7 Mike Foley 2014-08-22 13:49:06 EDT
i am seeing an incorrect link for "product documentation".  it is linking to jon 3.2 doc ...and not jon 3.3.

https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.2/index.html
Comment 8 Jay Shaughnessy 2014-09-09 11:36:36 EDT
This is because the 3.3 docs have yet to be generated and placed into official docs. Assigning this to Heiko because he is assigned to Bug 880359.
Comment 9 Jirka Kremser 2014-09-26 11:33:44 EDT
Doing what was mentioned in comment 8 ^
Comment 10 Simeon Pinder 2014-09-29 04:12:38 EDT
Moving into ER05 as didn't make the ER04 cut.
Comment 11 Heiko W. Rupp 2014-09-29 09:17:18 EDT
Zach,
can you please provide the links to the final content for the Mashup portlet as described in comment#5 ?

Thanks
Comment 12 Zach Rhoads 2014-10-02 10:31:30 EDT
linked related bug
Comment 19 Simeon Pinder 2014-10-21 16:24:14 EDT
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Note You need to log in before you can comment on or make changes to this bug.