This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1032579 - the gear does not recover after changing it's ip
the gear does not recover after changing it's ip
Status: CLOSED CANTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Parees
libra bugs
: Reopened, UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 07:23 EST by Oleg Fayans
Modified: 2016-11-30 19:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 11:32:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Fayans 2013-11-20 07:23:46 EST
Description of problem:
When I change the ip address of the local gear of a scalable application and then restart the app, the app becomes inaccessible and does not recover automatically. 

Version-Release number of selected component (if applicable):
ami-id: devenv_4053

How reproducible:
Always

Steps to Reproduce:
1. Create a scalable app
2. ssh into the app and issue the following command:
sed -i "s/local-gear .*:8080/local_gear 10.10.10.10:8080/" haproxy/conf/haproxy.cfg
3. restart the app

Actual results:
The app becomes inaccessible and returns 503 response code

Expected results:
The app gets recovered in several seconds


Additional info:
Comment 5 Ben Parees 2014-07-04 11:32:22 EDT
haproxy.cfg cannot be locked since it needs to be updated during scale up/down operations.  See https://bugzilla.redhat.com/show_bug.cgi?id=1012812 for more discussion on locking this file.

Note You need to log in before you can comment on or make changes to this bug.