Bug 1032584 - [RFE] spice proxy support at cluster/vm-pool granularity
[RFE] spice proxy support at cluster/vm-pool granularity
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: 3.4.0
Assigned To: Tomas Jelinek
Ilanit Stein
http://www.ovirt.org/Features/Spice_P...
virt
: FutureFeature
Depends On: 974076
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 07:31 EST by Michal Skrivanek
Modified: 2014-03-31 11:05 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 974076
Environment:
Last Closed: 2014-03-31 11:05:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 643983 None None None Never
oVirt gerrit 21518 None None None Never
oVirt gerrit 21519 None None None Never
oVirt gerrit 21631 None None None Never

  None (edit)
Description Michal Skrivanek 2013-11-20 07:31:33 EST
3.2 added spice proxy support as a global config. This RFE is to extend the support to allow configuration spice proxy per cluster, and per vm-pool (vm-pool configuration will override the cluster level if defined).
Comment 1 Sigbjorn Lie 2013-12-03 16:30:05 EST
Will there be added a possibility to automatically enable/disable the spice proxy based on where the user is accessing the User Portal from? 

We're evaluating Ovirt/RHEV for RHEL Client VDI and how we can access the Linux VDI machines from outside our LAN. We are required to accomplish this using a SSLVPN device having 2 factor autentication to satisfy company policy. 

However when the users access the VDI's from inside the LAN this proxy will not be available to them. Hence the request to be able to switch the spice proxy on/off for each session the user creates to the user portal, depending on if he's logging in from inside the network or remotely through the SSLVPN device.

This is functionality already found in other similar products. Asking the users to enable/disable the spice proxy manually will generate phone calls to our helpdesk and not be very user friendly.
Comment 2 Sandro Bonazzola 2014-01-13 08:57:09 EST
oVirt 3.4.0 alpha has been released including the fix for this issue.
Comment 3 Ilanit Stein 2014-03-18 08:01:38 EDT
Moving to verified, based on test plan passed on rhevm 3.4 av2: https://tcms.engineering.redhat.com/run/119097/?from_plan=12341
Comment 4 Sandro Bonazzola 2014-03-31 11:05:55 EDT
This is an automated message: moving to Closed CURRENT_RELEASE since oVirt 3.4.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.