Bug 1032593 - Data are kept in jboss-eap-6.2/standalone/data/wsdl after application undeploy
Data are kept in jboss-eap-6.2/standalone/data/wsdl after application undeploy
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: DR0
: EAP 6.3.0
Assigned To: Rebecca Searls
Rostislav Svoboda
Nidhi
:
Depends On: 1061340
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 07:51 EST by Rostislav Svoboda
Modified: 2014-06-28 11:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previous versions of JBoss EAP 6 stored data in Web Services Description Language (WSDL) directory (EAP_HOME/standalone/data/WSDL) even after an application was un-deployed from JBoss EAP server. The WSDL data was stored as this was the default behavior as soon as an application was deployed on the server with no automated mechanism for removing the stored files. This issue was resolved by updating files in repositories (jbossws-cxf-4.2.x and trunk) to change the behavior of maintaining and publishing WSDL logs. The fix prevents storage of data in WSDL directory after an application is un-deployed from JBoss EAP 6.3 server.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:42:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rostislav Svoboda 2013-11-20 07:51:11 EST
When you deploy and undeploy application there are still data present in jboss-eap-6.2/standalone/data/wsdl directory.

Start server in first terminal
[rsvoboda@steve 620CR2]$ jboss-eap-6.2/bin/standalone.sh

deploy && undeploy in second terminal
[rsvoboda@steve 620CR2]$ jboss-eap-6.2/bin/jboss-cli.sh -c
[standalone@localhost:9999 /] deploy /home/rsvoboda/git/eap-ws-management-tests/CLIWebservicesWsdlIT.war
[standalone@localhost:9999 /] undeploy CLIWebservicesWsdlIT.war
[standalone@localhost:9999 /] quit

Stop server using Ctrl+C in first terminal

Search for war
[rsvoboda@steve 620CR2]$ find . | grep war
./jboss-eap-6.2/standalone/data/wsdl/CLIWebservicesWsdlIT.war
./jboss-eap-6.2/standalone/data/wsdl/CLIWebservicesWsdlIT.war/AnnotatedSecurityService.wsdl


Is it intentional? Why would you need/want to keep wsdl data after service undeploy?
Comment 1 Alessio Soldano 2013-11-21 05:39:26 EST
There's simply never been a requirement for removing such files afair, I think they've always been left there.
Comment 3 Alessio Soldano 2013-12-10 17:41:16 EST
Upstream jira: https://issues.jboss.org/browse/JBWS-3744
Comment 4 Rostislav Svoboda 2013-12-19 04:14:23 EST
https://source.jboss.org/changelog/JBossWS?cs=18156  stack-cxf-jbossws-cxf-4.2.x
https://source.jboss.org/changelog/JBossWS?cs=18157  trunk
Comment 6 Kabir Khan 2014-04-04 10:56:01 EDT
Setting to ON_QA since upgrade should fix this
Comment 7 Petr Sakař 2014-04-08 06:48:50 EDT
Verified for EAP-6.3.0.ER1

Note You need to log in before you can comment on or make changes to this bug.