Bug 1032627 - /subsystem=logging/logger=any.category:assign-handler can't run under batch mode
/subsystem=logging/logger=any.category:assign-handler can't run under batch mode
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: Pending
: EAP 6.2.2
Assigned To: James Perkins
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 08:52 EST by Rafael Ruiz
Modified: 2014-06-02 08:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An erroneous name attribute was added to the logging model in a previous version of JBoss EAP. This resulted in the operation trying to add the final handler name to the logger or async-handler multiple times. To correct this behavior, the name attribute is no longer added to the model and the operation correctly gets the handler name from the operation context. In this release of the product, adding handlers to a logger or async-handler in a composite operation works correctly.
Story Points: ---
Clone Of: 1017881
Environment:
Last Closed: 2014-06-02 08:49:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1712 Minor Resolved Erroneous name attribute on root-logger after add-handler operation 2017-07-26 10:18 EDT

  None (edit)
Description Rafael Ruiz 2013-11-20 08:52:04 EST
+++ This bug was initially created as a clone of Bug #1017881 +++

Description of problem:

Any attempt to run /subsystem=logging/logger=org.jboss.as.quickstarts.logging:assign-handler(xxx on CLI under the batch gives the following error:

{"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => "JBAS011536: Handler XXXX is already assigned."}}

This error doens't happen if the commands are not under a batch transaction


Steps to Reproduce:
1. Checkout https://github.com/jboss-developer/jboss-eap-quickstarts/tree/master/logging
2. Execute JBOSS_HOME/bin/jboss-cli.sh --connect --file=configure-logging.cli


Actual results:
{"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => "JBAS011536: Handler FATAL_QS_ASYNC is already assigned."}}

Expected results:
The batch executed successfully


Additional info:

--- Additional comment from James Perkins on 2013-10-29 12:38:10 EDT ---

I'm giving this a devel_ack+, but I don't think we should target EAP 6.2 for the fix. I can see what the issue is, but it needs to be thought through a bit. We can work around it by using the handlers property.

Example:
/subsystem=logging/logger=org.jboss.as.quickstarts.logging:add(level=TRACE, handlers=[TRACE_QS_ASYNC,DEBUG_QS_ASYNC,INFO_QS_ASYNC,WARN_QS_ASYNC,ERROR_QS_ASYNC,FATAL_QS_ASYNC])

One additional note about the scripts, the :reload isn't needed. All logging operations, minus a write-attribute to the asyn-handler's queue-length, are applied at runtime.

--- Additional comment from James Perkins on 2013-10-29 12:45:44 EDT ---

I forgot to add. I think we should delay from EAP 6.2 because the workaround is easy enough. The error is only going to occur in composite operations when using multiple add-handler operations to the same logger. 

If we need to get this into 6.2 it is possible, but at this stage I'm not sure it's worth the change for the simple workaround. Also I doubt this use-case, adding handlers to the same logger in a composite operation, is used all that often. This same issue is present in EAP 6.1.x and it's the first time I've seen it.

--- Additional comment from James Perkins on 2013-10-29 14:03:39 EDT ---

A selected the incorrect flag, I should have nack'd this one. I apologize for that.

--- Additional comment from Rafael Ruiz on 2013-11-20 07:19:06 EST ---

I have same error with EAP 6.1.1. Regardless which category you add. Putting it outside batch it works.
Comment 2 Scott Mumford 2014-02-27 01:11:56 EST
This bug has been marked for inclusion in the 6.2.2 Release Notes.

To meet a PM request to have a draft of the document available for review by 4th March 2014, ECS requires assistance from someone involved with it's resolution.

If someone could review the Doc Text field above and fill out any blanks and correct any inaccuracies, a draft can be completed in a timely manner.
Comment 3 Scott Mumford 2014-03-02 23:00:40 EST
Reformatted Doc Text field to prose. Will mark as documented once a technical review of the  Release Notes document has been performed.
Comment 5 Nikoleta Ziakova 2014-03-04 03:22:24 EST
Verified with EAP 6.2.2.CP.CR2

Note You need to log in before you can comment on or make changes to this bug.