Bug 1032630 - rpmUtils.miscutils.rangeCheck ignores package release
rpmUtils.miscutils.rangeCheck ignores package release
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
20
All Linux
high Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 08:56 EST by Martin Kolman
Modified: 2013-11-20 09:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 09:03:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kolman 2013-11-20 08:56:18 EST
Description of problem:
The rangeCheck function ignores release id when checking if package satisfies package version request.

Version-Release number of selected component (if applicable):
yum-utils-1.1.31-18.fc20.noarch

How reproducible:
always

Steps to Reproduce:

>>> from rpmUtils import miscutils
>>> miscutils.rangeCheck(('python-blivet', '>=', ('', '0.23.5', '1.fc20')), ('python-blivet', 'noarch', '', '0.26', '1.fc21'))
>>> 1

Actual results:
1 is returned, meaning the ('python-blivet', 'noarch', '', '0.26', '1.fc21') satisfies the ('python-blivet', '>=', ('', '0.23.5', '1.fc20')) package request,
which is wrong, as the request and the package tuple have different release ids

Expected results:
0 is returned as the request & package tuples have different release ids

Additional info:
Official miscutils documentation: (includes rangeCheck documentation)
http://yum.baseurl.org/api/yum/rpmUtils/miscutils.html
Comment 1 Zdeněk Pavlas 2013-11-20 09:03:51 EST
Since "0.26-1.fc21" >= "0.23.5-1.fc20", I believe the check SHOULD return 1.

Note You need to log in before you can comment on or make changes to this bug.