Bug 103265 - Include unclassified packages in removal group view
Include unclassified packages in removal group view
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-28 05:44 EDT by Toralf
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 12:24:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2003-08-28 05:44:12 EDT
Description of problem:
Group view for "Remove Software" should perhaps have a special group for
packages that aren't included anywhere else. This would make it a lot easier to
keep the system "clean"; packages that aren't listed in any group (or other
packages' dependencies) typically represent add-on software installed
temporarily for testing purposes, or obsolete software left from earlier OS
releases.

Version-Release number of selected component (if applicable):
1.9.1-1
Comment 1 Jeremy Katz 2003-08-28 10:32:52 EDT
Why not just use the flat view (View->Packages)?
Comment 2 Toralf 2003-08-28 11:12:59 EDT
It has too much information.

Simply put, I want to single out the "bad" packages on my system. This is very
hard to do among a large crowd, but if someone would round up the usual suspects
for me, it might be very easy... 
Comment 3 Jeremy Katz 2003-08-28 11:29:31 EDT
The problem is that these "unclassified" packages are going to also include
library packages as they're not explicitly listed in the comps file and so
you're going to end up with the same sort of problem in an unclassified group.
Comment 4 Toralf 2003-08-28 12:18:36 EDT
Actually, it seems to me like library packages are indeed included in most cases
- they're not listed in groups, but they are mentioned in package dependencies.
Also, you could always leave out the ones that are required by packages in real
groups, but that would of course require a fair amount of extra parsing...
Comment 5 Jeremy Katz 2003-08-28 12:24:11 EDT
Yeah, it's pretty insanely slow to do that.  And you then have to keep it
updated as you remove things (if I remove A which is the only thing that
requires B, I then need to have B show up in the unclassified group, etc).  And
you could also end up having packages disappear from the group. 

Ugh, this seems increasingly like the sort of thing that just can't work very well

Note You need to log in before you can comment on or make changes to this bug.