Bug 1032674 - Make default physical block size 4K
Make default physical block size 4K
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On: 748906
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 09:58 EST by Paolo Bonzini
Modified: 2016-08-01 16:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 16:35:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2013-11-20 09:58:30 EST
For RHEL7.0, making physical block size 4K will make XFS use 4K blocks, and will avoid RMW operations when writing to the journal.

This is not expected to bring benefits for anything other than XFS, since LVM and parted are usually aligning things to 1MB anyway.

This is also the first step towards providing 4K native disks.  However, this requires UEFI support.
Comment 8 Kevin Wolf 2016-06-21 11:32:21 EDT
Paolo, do we still want this? I don't expect it to make a difference in practice
and apparently nobody was interested enough to bring it up again, but maybe it's
time to just make the change or close the BZ...
Comment 9 Paolo Bonzini 2016-07-15 03:14:48 EDT
I say close it... We can just do it upstream, there's no need for a BZ.
Comment 10 Kevin Wolf 2016-08-01 16:35:38 EDT
Ok, makes sense, I'm closing it now.

Note You need to log in before you can comment on or make changes to this bug.