Bug 1032675 - Process build errors reported multiple times
Process build errors reported multiple times
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER6
: 6.0.0
Assigned To: Kris Verlaenen
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 09:58 EST by Kris Verlaenen
Modified: 2015-06-01 21:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Verlaenen 2013-11-20 09:58:31 EST
When a project has multiple processes, process errors detected for one process are repeated for other processes that are parsed afterwards.  This is caused by the process builder being reused, but the list of errors not being cleared after each process has been built.
Comment 1 Kris Verlaenen 2013-11-20 10:48:14 EST
master: http://github.com/droolsjbpm/drools/commit/ae6a8d5c4
Comment 3 Jiri Svitak 2014-01-03 10:05:52 EST
Verified in BPMS 6 ER7 (6.0.1-redhat-2).

Note You need to log in before you can comment on or make changes to this bug.