Bug 1032681 - [abrt] yum-3.4.3-116.fc21: yumcommands.py:1612:doCommand:AttributeError: 'YumConf' object has no attribute 'autocheck_running_kernel'
[abrt] yum-3.4.3-116.fc21: yumcommands.py:1612:doCommand:AttributeError: 'Yum...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:617d14b39b1cb5c2ccb590e420f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 10:08 EST by David Sieg
Modified: 2013-11-21 03:37 EST (History)
5 users (show)

See Also:
Fixed In Version: yum-3.4.3-117.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 03:37:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.23 KB, text/plain)
2013-11-20 10:09 EST, David Sieg
no flags Details
File: environ (3.43 KB, text/plain)
2013-11-20 10:09 EST, David Sieg
no flags Details

  None (edit)
Description David Sieg 2013-11-20 10:08:53 EST
Description of problem:
The error message shows up after a 'yum check-update'. If I'm doing a normal upgrade/distro-sync everything seems to be normal (no error message).

Version-Release number of selected component:
yum-3.4.3-116.fc21

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/yum chk
executable:     /usr/bin/yum
kernel:         3.11.4-201.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
yumcommands.py:1612:doCommand:AttributeError: 'YumConf' object has no attribute 'autocheck_running_kernel'

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 355, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 174, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 569, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 1612, in doCommand
    if (base.conf.autocheck_running_kernel and
AttributeError: 'YumConf' object has no attribute 'autocheck_running_kernel'

Local variables in innermost frame:
basecmd: 'check-update'
cur: 'normal'
local_pkgs: {}
self: <yumcommands.CheckUpdateCommand instance at 0x7f73a154ec68>
ypl: <yum.misc.GenericHolder instance at 0x1780ab8>
extcmds: []
base: <cli.YumBaseCli object at 0x7f73a154a2d0>
typl: <yum.misc.GenericHolder instance at 0x1780a70>
obscmds: []
highlight: '\x1b[1m'
cul: 'bold'
po: <YumAvailablePackageSqlite : mjpegtools-libs-2.1.0-3.fc20.x86_64 (0x3625210)>
columns: (-58, -48, -22)
result: 100
Comment 1 David Sieg 2013-11-20 10:09:05 EST
Created attachment 826695 [details]
File: backtrace
Comment 2 David Sieg 2013-11-20 10:09:12 EST
Created attachment 826696 [details]
File: environ

Note You need to log in before you can comment on or make changes to this bug.