Bug 1032722 - Demos and Wagon
Demos and Wagon
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: 6.0.0
Assigned To: Eric Wittmann
Martin Vecera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 11:36 EST by Nick Cross
Modified: 2014-02-06 10:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Cross 2013-11-20 11:36:30 EST
In the build the demos require the s-ramp wagon to be built first. But Maven doesn't allow a build extension to be built in the same build as it is used (even if the wagon was built before the demos).

A workaround discussed with Eric would be to disable building of the demos via a profile (they would be built by default). They would still be packaged up into the distribution.
Comment 2 Eric Wittmann 2013-11-20 13:09:31 EST
Added a profile that includes the demos as child modules in the s-ramp-demos maven module.  This profile is active by default.  To deactivate it do:

-P!with-demos

May require escaping on the command line.  I successfully tested with:

mvn clean install -P\!with-demos
Comment 3 Martin Vecera 2013-12-20 06:45:58 EST
Verification still blocked on ER8 by https://bugzilla.redhat.com/show_bug.cgi?id=1041334
Comment 4 Martin Vecera 2013-12-20 06:48:26 EST
(In reply to Martin Vecera from comment #3)
> Verification still blocked on ER8 by
> https://bugzilla.redhat.com/show_bug.cgi?id=1041334

Sorry, wrong link. This is the correct one - https://bugzilla.redhat.com/show_bug.cgi?id=1043982

Probably caused by https://bugzilla.redhat.com/show_bug.cgi?id=1043425
Comment 5 Martin Vecera 2013-12-21 05:46:34 EST
Assigning back as this is still blocked by other bugs.
Comment 6 Eric Wittmann 2014-01-06 10:49:02 EST
This should be ready to test again in the next build (ER8-2?, ER9?) because BZ 1043982 should be fixed.

https://bugzilla.redhat.com/show_bug.cgi?id=1043982
Comment 7 Jiri Pechanec 2014-01-15 11:05:51 EST
Verified in CR1

Note You need to log in before you can comment on or make changes to this bug.