Bug 1032733 - Missing Reason-Phrase in HTTP response header for *standard* 3-digit status codes
Missing Reason-Phrase in HTTP response header for *standard* 3-digit status c...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: httpd (Show other bugs)
6.4
All All
unspecified Severity medium
: rc
: ---
Assigned To: Web Stack Team
Ondřej Pták
:
Depends On:
Blocks: 1150231 1162159
  Show dependency treegraph
 
Reported: 2013-11-20 11:48 EST by Justin Honold
Modified: 2014-11-10 07:08 EST (History)
7 users (show)

See Also:
Fixed In Version: httpd-2.2.15-35.el6
Doc Type: Bug Fix
Doc Text:
Cause: HTTP Reason-Phrase has not been added to the response if it included only Status code. Consequence: HTTP clients could see only Status code without the Reason-Phrase. Fix: HTTP Reason-Phrase is now added to the Status line even when original response contained only Status code. Result: HTTP clients see Reason-Phrase in the response as expected.
Story Points: ---
Clone Of:
: 1150231 1162159 (view as bug list)
Environment:
Last Closed: 2014-10-14 04:07:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1386 normal SHIPPED_LIVE httpd bug fix and enhancement update 2014-10-13 21:27:20 EDT

  None (edit)
Description Justin Honold 2013-11-20 11:48:59 EST
Description of problem: a combination of Apache HTTPD Server + Phusion Passenger 3.x will strip Reason-Phrases from status responses, leading to breakage of clients which rely on them.


Version-Release number of selected component (if applicable): httpd-2.2.15-29.el6.centos.x86_64, passenger (3.0.18)


How reproducible: 100%


Steps to Reproduce:
1. install httpd
2. install Passenger 3.0.18 via Ruby Gems
3. curl -sv http://URL/ 2>&1|grep 'HTTP/1.1 200'

Actual results: < HTTP/1.1 200


Expected results: < HTTP/1.1 200 OK


Additional info: while Reason-Phrases aren't explicitly necessary per the RFC, even Apache themselves have imported a fix into 2.4 and higher as per https://issues.apache.org/bugzilla/show_bug.cgi?id=54946
Comment 1 Justin Honold 2013-11-20 11:50:04 EST
I should note - to reproduce, you do actually need to host a minimal Passenger-driven site.  The Apache issue has all kinds of details already, though, and an apparently-working patch.
Comment 3 Joe Orton 2013-11-20 12:03:08 EST
Thank you for taking the time to enter a bug report with us. We appreciate the feedback and look to use reports such as this to guide our efforts at improving our products. That being said, this bug tracking system is not a mechanism for requesting support, and we are not able to  guarantee the timeliness or suitability of a resolution.

If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain  it receives the proper attention and prioritization to assure a timely resolution. 

For information on how to contact the Red Hat production support team, please visit:

https://www.redhat.com/support/process/production/#howto
Comment 12 Ondřej Pták 2014-09-15 05:59:51 EDT
httpd-2.2.15-29.el6
===================
:: [   PASS   ] :: Command 'curl -D header.log http://localhost/webapps/ > page' (Expected 0, got 0)
:: [   PASS   ] :: File 'page' should contain 'hello world' 
:: [   PASS   ] :: File 'header.log' should contain '200' 
:: [   FAIL   ] :: File 'header.log' should contain '200 OK' 


httpd-2.2.15-39.el6
===================
:: [   PASS   ] :: Command 'curl -D header.log http://localhost/webapps/ > page' (Expected 0, got 0)
:: [   PASS   ] :: File 'page' should contain 'hello world' 
:: [   PASS   ] :: File 'header.log' should contain '200' 
:: [   PASS   ] :: File 'header.log' should contain '200 OK'
Comment 13 errata-xmlrpc 2014-10-14 04:07:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1386.html

Note You need to log in before you can comment on or make changes to this bug.